aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Protocol-CassandraCQL
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-28 12:10:12 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-28 12:10:12 +0000
commit8096f7d5b1800486370e60250282b96e88efc015 (patch)
treed68a99134b51c3db03301aaeaf785dd722ba0173 /databases/p5-Protocol-CassandraCQL
parentde8afdb9eed40eb4d7340851704059aaf8c52f11 (diff)
downloadports-8096f7d5b1800486370e60250282b96e88efc015.tar.gz
ports-8096f7d5b1800486370e60250282b96e88efc015.zip
New port: databases/p5-Protocol-CassandraCQL
This module provides the basic constants and other support functions required to communicate with a Cassandra database using CQL3. It is not in itself a CQL client; it simply provides the necessary support functions to allow one to be written. For a complete client, see instead Net::Async::CassandraCQL. WWW: http://search.cpan.org/dist/Protocol-CassandraCQL/ PR: 186055 Submitted by: admins@perceptyx.com
Notes
Notes: svn path=/head/; revision=366398
Diffstat (limited to 'databases/p5-Protocol-CassandraCQL')
-rw-r--r--databases/p5-Protocol-CassandraCQL/Makefile26
-rw-r--r--databases/p5-Protocol-CassandraCQL/distinfo2
-rw-r--r--databases/p5-Protocol-CassandraCQL/pkg-descr8
-rw-r--r--databases/p5-Protocol-CassandraCQL/pkg-plist19
4 files changed, 55 insertions, 0 deletions
diff --git a/databases/p5-Protocol-CassandraCQL/Makefile b/databases/p5-Protocol-CassandraCQL/Makefile
new file mode 100644
index 000000000000..6d4335749f9d
--- /dev/null
+++ b/databases/p5-Protocol-CassandraCQL/Makefile
@@ -0,0 +1,26 @@
+# Created by: Denis Shaposhnikov <dsh@bamus.cz>
+# $FreeBSD$
+
+PORTNAME= Protocol-CassandraCQL
+PORTVERSION= 0.11
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PEVANS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= admins@perceptyx.com
+COMMENT= Wire protocol support functions for Cassandra CQL3
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Compress-Snappy>0:${PORTSDIR}/archivers/p5-Compress-Snappy \
+ p5-IO-Socket-IP>0:${PORTSDIR}/net/p5-IO-Socket-IP \
+ p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-HexString>0:${PORTSDIR}/devel/p5-Test-HexString
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Protocol-CassandraCQL/distinfo b/databases/p5-Protocol-CassandraCQL/distinfo
new file mode 100644
index 000000000000..c0d3a8400c17
--- /dev/null
+++ b/databases/p5-Protocol-CassandraCQL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Protocol-CassandraCQL-0.11.tar.gz) = ea260d43e421ba848c3d366457728ef4c1e0a8086404b7c0034893c9aa87d089
+SIZE (Protocol-CassandraCQL-0.11.tar.gz) = 41598
diff --git a/databases/p5-Protocol-CassandraCQL/pkg-descr b/databases/p5-Protocol-CassandraCQL/pkg-descr
new file mode 100644
index 000000000000..daf01b7134f4
--- /dev/null
+++ b/databases/p5-Protocol-CassandraCQL/pkg-descr
@@ -0,0 +1,8 @@
+This module provides the basic constants and other support functions
+required to communicate with a Cassandra database using CQL3. It is
+not in itself a CQL client; it simply provides the necessary support
+functions to allow one to be written.
+
+For a complete client, see instead Net::Async::CassandraCQL.
+
+WWW: http://search.cpan.org/dist/Protocol-CassandraCQL/
diff --git a/databases/p5-Protocol-CassandraCQL/pkg-plist b/databases/p5-Protocol-CassandraCQL/pkg-plist
new file mode 100644
index 000000000000..d391e84c2b1c
--- /dev/null
+++ b/databases/p5-Protocol-CassandraCQL/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/Protocol/CassandraCQL.pm
+%%SITE_PERL%%/Protocol/CassandraCQL/Client.pm
+%%SITE_PERL%%/Protocol/CassandraCQL/ColumnMeta.pm
+%%SITE_PERL%%/Protocol/CassandraCQL/Frame.pm
+%%SITE_PERL%%/Protocol/CassandraCQL/Frames.pm
+%%SITE_PERL%%/Protocol/CassandraCQL/Result.pm
+%%SITE_PERL%%/Protocol/CassandraCQL/Type.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol/CassandraCQL/.packlist
+%%PERL5_MAN3%%/Protocol::CassandraCQL.3.gz
+%%PERL5_MAN3%%/Protocol::CassandraCQL::Client.3.gz
+%%PERL5_MAN3%%/Protocol::CassandraCQL::ColumnMeta.3.gz
+%%PERL5_MAN3%%/Protocol::CassandraCQL::Frame.3.gz
+%%PERL5_MAN3%%/Protocol::CassandraCQL::Frames.3.gz
+%%PERL5_MAN3%%/Protocol::CassandraCQL::Result.3.gz
+%%PERL5_MAN3%%/Protocol::CassandraCQL::Type.3.gz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol/CassandraCQL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol
+@dirrmtry %%SITE_PERL%%/Protocol/CassandraCQL
+@dirrmtry %%SITE_PERL%%/Protocol