aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-SQL-Abstract-Classic
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-07-24 07:07:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-07-24 07:07:48 +0000
commit575fc398bf7858b67f8fd1ea042501494a951484 (patch)
tree1c70ffcc49f241ee655aadba95785540273d41b4 /databases/p5-SQL-Abstract-Classic
parent58efef7d05464c6fd7ecf49929b98fc11c160f84 (diff)
downloadports-575fc398bf7858b67f8fd1ea042501494a951484.tar.gz
ports-575fc398bf7858b67f8fd1ea042501494a951484.zip
Add p5-SQL-Abstract-Classic 1.91
SQL::Abstract::Classic was inspired by the excellent DBIx::Abstract. However, in using that module I found that what I really wanted to do was generate SQL, but still retain complete control over my statement handles and use the DBI interface. So, I set out to create an abstract SQL generation module. While based on the concepts used by DBIx::Abstract, there are several important differences, especially when it comes to WHERE clauses. I have modified the concepts used to make the SQL easier to generate from Perl data structures and, IMO, more intuitive. The underlying idea is for this module to do what you mean, based on the data structures you provide it. The big advantage is that you don't have to modify your code every time your data changes, as this module figures it out. WWW: https://metacpan.org/release/SQL-Abstract-Classic
Notes
Notes: svn path=/head/; revision=543008
Diffstat (limited to 'databases/p5-SQL-Abstract-Classic')
-rw-r--r--databases/p5-SQL-Abstract-Classic/Makefile25
-rw-r--r--databases/p5-SQL-Abstract-Classic/distinfo3
-rw-r--r--databases/p5-SQL-Abstract-Classic/pkg-descr14
-rw-r--r--databases/p5-SQL-Abstract-Classic/pkg-plist4
4 files changed, 46 insertions, 0 deletions
diff --git a/databases/p5-SQL-Abstract-Classic/Makefile b/databases/p5-SQL-Abstract-Classic/Makefile
new file mode 100644
index 000000000000..61fb70aebc28
--- /dev/null
+++ b/databases/p5-SQL-Abstract-Classic/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= SQL-Abstract-Classic
+PORTVERSION= 1.91
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Generate SQL from Perl data structures
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-MRO-Compat>=0.12:devel/p5-MRO-Compat \
+ p5-SQL-Abstract>=1.79:databases/p5-SQL-Abstract
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/databases/p5-SQL-Abstract-Classic/distinfo b/databases/p5-SQL-Abstract-Classic/distinfo
new file mode 100644
index 000000000000..6cb6590daa12
--- /dev/null
+++ b/databases/p5-SQL-Abstract-Classic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595416503
+SHA256 (SQL-Abstract-Classic-1.91.tar.gz) = 4e3d1dfd095b2123268586bb06b86929ea571388d4e941acccbdcda1e108ef28
+SIZE (SQL-Abstract-Classic-1.91.tar.gz) = 78466
diff --git a/databases/p5-SQL-Abstract-Classic/pkg-descr b/databases/p5-SQL-Abstract-Classic/pkg-descr
new file mode 100644
index 000000000000..d1d5d34420b8
--- /dev/null
+++ b/databases/p5-SQL-Abstract-Classic/pkg-descr
@@ -0,0 +1,14 @@
+SQL::Abstract::Classic was inspired by the excellent DBIx::Abstract. However, in
+using that module I found that what I really wanted to do was generate SQL, but
+still retain complete control over my statement handles and use the DBI
+interface. So, I set out to create an abstract SQL generation module.
+
+While based on the concepts used by DBIx::Abstract, there are several important
+differences, especially when it comes to WHERE clauses. I have modified the
+concepts used to make the SQL easier to generate from Perl data structures and,
+IMO, more intuitive. The underlying idea is for this module to do what you mean,
+based on the data structures you provide it. The big advantage is that you don't
+have to modify your code every time your data changes, as this module figures it
+out.
+
+WWW: https://metacpan.org/release/SQL-Abstract-Classic
diff --git a/databases/p5-SQL-Abstract-Classic/pkg-plist b/databases/p5-SQL-Abstract-Classic/pkg-plist
new file mode 100644
index 000000000000..e6c432681e53
--- /dev/null
+++ b/databases/p5-SQL-Abstract-Classic/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/SQL/Abstract/Classic.pm
+%%SITE_PERL%%/SQL/Abstract/Util.pm
+%%PERL5_MAN3%%/SQL::Abstract::Classic.3.gz
+%%PERL5_MAN3%%/SQL::Abstract::Util.3.gz