aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Test-DatabaseRow
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-07 10:44:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-07 10:44:40 +0000
commit4a1c0ea7a29e518fe7777b592d0b11c296aa469d (patch)
tree78628504562d837337d10b91d44dd333396460cc /databases/p5-Test-DatabaseRow
parentf07758714f3f72c5fcea2189c3bfd7b9255e9b97 (diff)
downloadports-4a1c0ea7a29e518fe7777b592d0b11c296aa469d.tar.gz
ports-4a1c0ea7a29e518fe7777b592d0b11c296aa469d.zip
This is a simple module for doing very very simple quick tests on a
database, primarily designed to test if a row exists with the correct details in a table or not. For more advanced testing (joins, etc) it's probably easier for you to roll your own tests by hand than use this module. WWW: http://search.cpan.org/~mark/Test-DatabaseRow-1.04/ PR: ports/98608 Submitted by: Joshua D. Abraham <jabra@ccs.neu.edu>
Notes
Notes: svn path=/head/; revision=164690
Diffstat (limited to 'databases/p5-Test-DatabaseRow')
-rw-r--r--databases/p5-Test-DatabaseRow/Makefile35
-rw-r--r--databases/p5-Test-DatabaseRow/distinfo3
-rw-r--r--databases/p5-Test-DatabaseRow/pkg-descr7
-rw-r--r--databases/p5-Test-DatabaseRow/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/databases/p5-Test-DatabaseRow/Makefile b/databases/p5-Test-DatabaseRow/Makefile
new file mode 100644
index 000000000000..568a1ab31337
--- /dev/null
+++ b/databases/p5-Test-DatabaseRow/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Test-DatabaseRow
+# Date created: June 3 2006
+# Whom: Joshua D. Abraham <jabra@ccs.neu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-DatabaseRow
+PORTVERSION= 1.04
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MA/MARKF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jabra@ccs.neu.edu
+COMMENT= Simple database tests
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Test/Builder/Module.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::DatabaseRow.3
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Test-DatabaseRow/distinfo b/databases/p5-Test-DatabaseRow/distinfo
new file mode 100644
index 000000000000..48ecbb9af755
--- /dev/null
+++ b/databases/p5-Test-DatabaseRow/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-DatabaseRow-1.04.tar.gz) = e63d7ef63451f438074ab33e19c7cd09
+SHA256 (Test-DatabaseRow-1.04.tar.gz) = 81ef7de9d0b6383416a28969d67a1e6453fdd8e7801bc4e5dfc7946eaa2b59e0
+SIZE (Test-DatabaseRow-1.04.tar.gz) = 14377
diff --git a/databases/p5-Test-DatabaseRow/pkg-descr b/databases/p5-Test-DatabaseRow/pkg-descr
new file mode 100644
index 000000000000..728040f19c37
--- /dev/null
+++ b/databases/p5-Test-DatabaseRow/pkg-descr
@@ -0,0 +1,7 @@
+This is a simple module for doing very very simple quick tests on a
+database, primarily designed to test if a row exists with the correct
+details in a table or not. For more advanced testing (joins, etc) it's
+probably easier for you to roll your own tests by hand than use this
+module.
+
+WWW: http://search.cpan.org/~mark/Test-DatabaseRow-1.04/
diff --git a/databases/p5-Test-DatabaseRow/pkg-plist b/databases/p5-Test-DatabaseRow/pkg-plist
new file mode 100644
index 000000000000..ea84e97715f4
--- /dev/null
+++ b/databases/p5-Test-DatabaseRow/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/DatabaseRow/.packlist
+%%SITE_PERL%%/Test/DatabaseRow.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/DatabaseRow
+@dirrmtry %%SITE_PERL%%/Test
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test