aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-TokyoCabinet
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /databases/p5-TokyoCabinet
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'databases/p5-TokyoCabinet')
-rw-r--r--databases/p5-TokyoCabinet/Makefile1
-rw-r--r--databases/p5-TokyoCabinet/pkg-plist19
2 files changed, 10 insertions, 10 deletions
diff --git a/databases/p5-TokyoCabinet/Makefile b/databases/p5-TokyoCabinet/Makefile
index c32416f728ae..b8e1d79fcbeb 100644
--- a/databases/p5-TokyoCabinet/Makefile
+++ b/databases/p5-TokyoCabinet/Makefile
@@ -2,6 +2,7 @@
PORTNAME= TokyoCabinet
PORTVERSION= 1.34
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://fallabs.com/tokyocabinet/perlpkg/
diff --git a/databases/p5-TokyoCabinet/pkg-plist b/databases/p5-TokyoCabinet/pkg-plist
index 239b1f0af582..71d4c6d80558 100644
--- a/databases/p5-TokyoCabinet/pkg-plist
+++ b/databases/p5-TokyoCabinet/pkg-plist
@@ -1,11 +1,10 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/TokyoCabinet.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/TokyoCabinet.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/TokyoCabinet/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/TokyoCabinet/TokyoCabinet.so
-%%SITE_PERL%%/%%PERL_ARCH%%/memsize.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/tcatest.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/tcbtest.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/tcftest.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/tchtest.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/tcttest.pl
+%%SITE_ARCH%%/TokyoCabinet.pm
+%%SITE_ARCH%%/TokyoCabinet.pod
+%%SITE_ARCH%%/auto/TokyoCabinet/TokyoCabinet.so
+%%SITE_ARCH%%/memsize.pl
+%%SITE_ARCH%%/tcatest.pl
+%%SITE_ARCH%%/tcbtest.pl
+%%SITE_ARCH%%/tcftest.pl
+%%SITE_ARCH%%/tchtest.pl
+%%SITE_ARCH%%/tcttest.pl
%%PERL5_MAN3%%/TokyoCabinet.3.gz