aboutsummaryrefslogtreecommitdiff
path: root/databases/pear-DB_DataObject
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /databases/pear-DB_DataObject
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'databases/pear-DB_DataObject')
-rw-r--r--databases/pear-DB_DataObject/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/pear-DB_DataObject/Makefile b/databases/pear-DB_DataObject/Makefile
index 371149123bbe..99e1438f9501 100644
--- a/databases/pear-DB_DataObject/Makefile
+++ b/databases/pear-DB_DataObject/Makefile
@@ -11,10 +11,10 @@ COMMENT= SQL Builder, Object Interface to Database Tables
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/docs/LICENCE.txt
-BUILD_DEPENDS= pear-DB>=1.7.0:databases/pear-DB \
- pear-Date>=1.4.3:devel/pear-Date
-RUN_DEPENDS= pear-DB>=1.7.0:databases/pear-DB \
- pear-Date>=1.4.3:devel/pear-Date
+BUILD_DEPENDS= ${PEAR_PKGNAMEPREFIX}DB>=1.7.0:databases/pear-DB@${PHP_FLAVOR} \
+ ${PEAR_PKGNAMEPREFIX}Date>=1.4.3:devel/pear-Date@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}DB>=1.7.0:databases/pear-DB@${PHP_FLAVOR} \
+ ${PEAR_PKGNAMEPREFIX}Date>=1.4.3:devel/pear-Date@${PHP_FLAVOR}
USES= pear
@@ -23,7 +23,7 @@ OPTIONS_DEFINE= PEAR_MDB2 PEAR_VALIDATE
PEAR_MDB2_DESC= PEAR::MDB2 support
PEAR_VALIDATE_DESC= PEAR::Validate support
-PEAR_MDB2_RUN_DEPENDS= pear-MDB2>=2.3.0:databases/pear-MDB2
-PEAR_VALIDATE_RUN_DEPENDS= pear-Validate>=0.1.1:devel/pear-Validate
+PEAR_MDB2_RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}MDB2>=2.3.0:databases/pear-MDB2@${PHP_FLAVOR}
+PEAR_VALIDATE_RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Validate>=0.1.1:devel/pear-Validate@${PHP_FLAVOR}
.include <bsd.port.mk>