aboutsummaryrefslogtreecommitdiff
path: root/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /databases/pear-Structures_DataGrid_DataSource_DB/Makefile
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'databases/pear-Structures_DataGrid_DataSource_DB/Makefile')
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DB/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/pear-Structures_DataGrid_DataSource_DB/Makefile b/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
index 6663dc35c90f..cba2c00b4102 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
@@ -8,9 +8,9 @@ CATEGORIES= databases www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= DB datasource driver for pear-Structures_DataGrid
-RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid \
- ${PEARDIR}/DB.php:databases/pear-DB \
- ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:databases/pear-Structures_DataGrid_DataSource_Array
+RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
+ ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR} \
+ ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:databases/pear-Structures_DataGrid_DataSource_Array@${PHP_FLAVOR}
USES= pear