aboutsummaryrefslogtreecommitdiff
path: root/databases/pecl-memcache
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-27 11:51:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-27 11:51:41 +0000
commite4084c6f633bb51c88daf46a947d72c76769ff74 (patch)
tree3ba7f92f6901dd835b675c9df83b619a076c398b /databases/pecl-memcache
parent80aac3925642526faee4ac37f9ce0f4a347fd68c (diff)
downloadports-e4084c6f633bb51c88daf46a947d72c76769ff74.tar.gz
ports-e4084c6f633bb51c88daf46a947d72c76769ff74.zip
Resurrect databases/pecl-memcache and update to 4.0.4
Changes: https://github.com/websupport-sk/pecl-memcache/releases PR: 239320 Submitted by: Daniel Morante <daniel@morante.net>
Notes
Notes: svn path=/head/; revision=507397
Diffstat (limited to 'databases/pecl-memcache')
-rw-r--r--databases/pecl-memcache/Makefile30
-rw-r--r--databases/pecl-memcache/distinfo3
-rw-r--r--databases/pecl-memcache/pkg-descr5
-rw-r--r--databases/pecl-memcache/pkg-plist1
4 files changed, 39 insertions, 0 deletions
diff --git a/databases/pecl-memcache/Makefile b/databases/pecl-memcache/Makefile
new file mode 100644
index 000000000000..3ea633d8d32c
--- /dev/null
+++ b/databases/pecl-memcache/Makefile
@@ -0,0 +1,30 @@
+# Created by: Gerrit Beine <tux@pinguru.net>
+# $FreeBSD$
+
+PORTNAME= memcache
+PORTVERSION= 4.0.4
+CATEGORIES= databases
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Unofficial Memcached extension
+
+LICENSE= PHP30
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= EXAMPLES
+
+USES= dos2unix php:pecl
+USE_PHP= session:build zlib:build
+
+CONFIGURE_ARGS= --with-zlib-dir=/usr
+USE_CSTD= gnu89
+
+USE_GITHUB= yes
+GH_ACCOUNT= websupport-sk
+GH_PROJECT= pecl-memcache
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/example.php ${STAGEDIR}${EXAMPLESDIR}/
+
+.include <bsd.port.mk>
diff --git a/databases/pecl-memcache/distinfo b/databases/pecl-memcache/distinfo
new file mode 100644
index 000000000000..836ff7faa720
--- /dev/null
+++ b/databases/pecl-memcache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1564159352
+SHA256 (PECL/websupport-sk-pecl-memcache-4.0.4_GH0.tar.gz) = 022607027e31f63c8bf7958a334743ca7c2a1058b3b5fe6e0aea67926954facf
+SIZE (PECL/websupport-sk-pecl-memcache-4.0.4_GH0.tar.gz) = 75906
diff --git a/databases/pecl-memcache/pkg-descr b/databases/pecl-memcache/pkg-descr
new file mode 100644
index 000000000000..851bf2a4e2a5
--- /dev/null
+++ b/databases/pecl-memcache/pkg-descr
@@ -0,0 +1,5 @@
+Memcached is a caching daemon designed especially for dynamic web applications
+to decrease database load by storing objects in memory. This extension allows
+you to work with memcached through handy OO and procedural interfaces.
+
+WWW: https://github.com/websupport-sk/pecl-memcache
diff --git a/databases/pecl-memcache/pkg-plist b/databases/pecl-memcache/pkg-plist
new file mode 100644
index 000000000000..5c859776e721
--- /dev/null
+++ b/databases/pecl-memcache/pkg-plist
@@ -0,0 +1 @@
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.php