aboutsummaryrefslogtreecommitdiff
path: root/databases/pecl-rrd
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-09-07 14:35:46 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-09-07 14:35:46 +0000
commita2d6adbede88c81b2e3c518ae390730367cd8ce4 (patch)
treeae317f8b1582f2e620736cf85e73efa5ba09f252 /databases/pecl-rrd
parent9c3518ceec8c1fd261c4982d3faab642ba616229 (diff)
downloadports-a2d6adbede88c81b2e3c518ae390730367cd8ce4.tar.gz
ports-a2d6adbede88c81b2e3c518ae390730367cd8ce4.zip
databases/pecl-rrd: Update to version 2.0.1 and limit php support to
versions 7.0 and later. PR: 219939 Submitted by: daniel@blodan.se Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=449401
Diffstat (limited to 'databases/pecl-rrd')
-rw-r--r--databases/pecl-rrd/Makefile10
-rw-r--r--databases/pecl-rrd/distinfo5
-rw-r--r--databases/pecl-rrd/files/patch-rrd.c81
3 files changed, 6 insertions, 90 deletions
diff --git a/databases/pecl-rrd/Makefile b/databases/pecl-rrd/Makefile
index 631c65250e25..10a0e7bc86ce 100644
--- a/databases/pecl-rrd/Makefile
+++ b/databases/pecl-rrd/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= rrd
-DISTVERSION= 1.1.3
-PORTREVISION= 4
+DISTVERSION= 2.0.1
CATEGORIES= databases pear
MAINTAINER= flo@FreeBSD.org
@@ -10,11 +9,8 @@ COMMENT= PHP bindings to rrd tool system
LICENSE= PHP301
+IGNORE_WITH_PHP=56
LIB_DEPENDS= librrd.so:databases/rrdtool
-
-LDFLAGS+= -L${LOCALBASE}/lib
-
-USES= php:pecl
-IGNORE_WITH_PHP= 70
+USES= php:pecl localbase pkgconfig
.include <bsd.port.mk>
diff --git a/databases/pecl-rrd/distinfo b/databases/pecl-rrd/distinfo
index af5f7c091750..e31049fe6644 100644
--- a/databases/pecl-rrd/distinfo
+++ b/databases/pecl-rrd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (PECL/rrd-1.1.3.tgz) = 0415ac51e09fe2e7a999d155d10d6af42ddf40ab0b4847a63ed1f9458533858e
-SIZE (PECL/rrd-1.1.3.tgz) = 19229
+TIMESTAMP = 1497340386
+SHA256 (PECL/rrd-2.0.1.tgz) = 39f5ae515de003d8dad6bfd77db60f5bd5b4a9f6caa41479b1b24b0d6592715d
+SIZE (PECL/rrd-2.0.1.tgz) = 18880
diff --git a/databases/pecl-rrd/files/patch-rrd.c b/databases/pecl-rrd/files/patch-rrd.c
deleted file mode 100644
index 2140a8be3c92..000000000000
--- a/databases/pecl-rrd/files/patch-rrd.c
+++ /dev/null
@@ -1,81 +0,0 @@
---- rrd.c.orig 2016-01-12 12:42:39 UTC
-+++ rrd.c
-@@ -19,7 +19,9 @@
- #include <rrd.h>
-
- #include "php_rrd.h"
-+#ifdef HAVE_RRD_GRAPH
- #include "rrd_graph.h"
-+#endif
- #include "rrd_create.h"
- #include "rrd_update.h"
- #include "rrd_info.h"
-@@ -387,6 +389,7 @@ PHP_FUNCTION(rrd_tune)
- }
- /* }}} */
-
-+#ifdef HAVE_RRD_GRAPH
- /* {{{ proto array rrd_xport(array options)
- * Creates a graph based on options passed via an array
- */
-@@ -480,6 +483,7 @@ PHP_FUNCTION(rrd_xport)
- free(data);
- }
- /* }}} */
-+#endif
-
- #ifdef HAVE_RRDC_DISCONNECT
- /* {{{ proto void rrdc_disconnect()
-@@ -537,18 +541,22 @@ ZEND_BEGIN_ARG_INFO(arginfo_rrd_tune, 0)
- ZEND_ARG_INFO(0, options)
- ZEND_END_ARG_INFO()
-
-+#ifdef HAVE_RRD_GRAPH
- ZEND_BEGIN_ARG_INFO(arginfo_rrd_xport, 0)
- ZEND_ARG_INFO(0, options)
- ZEND_END_ARG_INFO()
-+#endif
-
- ZEND_BEGIN_ARG_INFO(arginfo_rrd_info, 0)
- ZEND_ARG_INFO(0, file)
- ZEND_END_ARG_INFO()
-
-+#ifdef HAVE_RRD_GRAPH
- ZEND_BEGIN_ARG_INFO(arginfo_rrd_graph, 0)
- ZEND_ARG_INFO(0, file)
- ZEND_ARG_INFO(0, options)
- ZEND_END_ARG_INFO()
-+#endif
-
- ZEND_BEGIN_ARG_INFO(arginfo_rrd_create, 0)
- ZEND_ARG_INFO(0, filename)
-@@ -565,7 +573,9 @@ ZEND_END_ARG_INFO()
- static zend_function_entry rrd_functions[] = {
- PHP_FE(rrd_update, arginfo_rrd_update)
- PHP_FE(rrd_create, arginfo_rrd_create)
-+#ifdef HAVE_RRD_GRAPH
- PHP_FE(rrd_graph, arginfo_rrd_graph)
-+#endif
- PHP_FE(rrd_error, NULL)
- PHP_FE(rrd_fetch, arginfo_rrd_fetch)
- PHP_FE(rrd_first, arginfo_rrd_first)
-@@ -574,7 +584,9 @@ static zend_function_entry rrd_functions
- PHP_FE(rrd_lastupdate, arginfo_rrd_lastupdate)
- PHP_FE(rrd_restore, arginfo_rrd_restore)
- PHP_FE(rrd_tune, arginfo_rrd_tune)
-+#ifdef HAVE_RRD_GRAPH
- PHP_FE(rrd_xport, arginfo_rrd_xport)
-+#endif
- #ifdef HAVE_RRDC_DISCONNECT
- PHP_FE(rrdc_disconnect, NULL)
- #endif
-@@ -590,7 +602,9 @@ static zend_function_entry rrd_functions
- /* {{{ PHP_MINIT_FUNCTION */
- static PHP_MINIT_FUNCTION(rrd)
- {
-+#ifdef HAVE_RRD_GRAPH
- rrd_graph_minit(TSRMLS_C);
-+#endif
- rrd_create_minit(TSRMLS_C);
- rrd_update_minit(TSRMLS_C);
- return SUCCESS;