aboutsummaryrefslogtreecommitdiff
path: root/databases/percona57-pam-for-mysql
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-10-01 09:30:03 +0000
committerRene Ladan <rene@FreeBSD.org>2023-10-01 09:30:03 +0000
commit438a30ec44e27e6c183b085f4a5c6479e1bcbbad (patch)
tree82c6cd3af533c4d71f07ca486964a187ef06ee6d /databases/percona57-pam-for-mysql
parent7ba41b9e4e4b3a7b1494c0bd858577c25395efa9 (diff)
downloadports-438a30ec44e27e6c183b085f4a5c6479e1bcbbad.tar.gz
ports-438a30ec44e27e6c183b085f4a5c6479e1bcbbad.zip
Diffstat (limited to 'databases/percona57-pam-for-mysql')
-rw-r--r--databases/percona57-pam-for-mysql/Makefile31
-rw-r--r--databases/percona57-pam-for-mysql/files/pam.conf12
-rw-r--r--databases/percona57-pam-for-mysql/files/patch-cmake_build__configurations_compiler__options.cmake20
-rw-r--r--databases/percona57-pam-for-mysql/files/patch-cmake_os_DragonFly.cmake27
-rw-r--r--databases/percona57-pam-for-mysql/files/patch-cmake_os_FreeBSD.cmake25
-rw-r--r--databases/percona57-pam-for-mysql/pkg-descr1
-rw-r--r--databases/percona57-pam-for-mysql/pkg-message16
-rw-r--r--databases/percona57-pam-for-mysql/pkg-plist4
8 files changed, 0 insertions, 136 deletions
diff --git a/databases/percona57-pam-for-mysql/Makefile b/databases/percona57-pam-for-mysql/Makefile
deleted file mode 100644
index 9614290ce116..000000000000
--- a/databases/percona57-pam-for-mysql/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-PORTNAME= percona57
-PORTREVISION?= 0
-PKGNAMESUFFIX= -pam-for-mysql
-
-COMMENT= PAM plugin for MySQL
-WWW= https://www.percona.com/
-
-LICENSE= GPLv2+
-
-RUN_DEPENDS=# This plugin has no run dependencies. It should work with any desired mysql client/server.
-
-MASTERDIR= ${.CURDIR}/../percona57-server
-
-PKGMESSAGE= ${.CURDIR}/pkg-message
-PATCHDIR= ${MASTERDIR}/files
-FILESDIR= ${.CURDIR}/files
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${.CURDIR}/pkg-descr
-
-CONFLICTS_INSTALL= percona5[0-68-9]-pam-for-mysql* \
- percona-pam-for-mysql*
-
-CMAKE_ARGS+= -DWITH_PAM=1
-
-PLUGIN_ONLY= yes
-
-do-install:
- (cd ${WRKSRC}/plugin/percona-pam-for-mysql && ${MAKE} ${MAKE_ARGS} install)
- ${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/mysqld.sample
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/percona57-pam-for-mysql/files/pam.conf b/databases/percona57-pam-for-mysql/files/pam.conf
deleted file mode 100644
index 0e75199574ba..000000000000
--- a/databases/percona57-pam-for-mysql/files/pam.conf
+++ /dev/null
@@ -1,12 +0,0 @@
-#
-# PAM configuration for the "mysqld" service
-#
-
-# auth
-auth include system
-
-# account
-account include system
-
-# password
-password include system
diff --git a/databases/percona57-pam-for-mysql/files/patch-cmake_build__configurations_compiler__options.cmake b/databases/percona57-pam-for-mysql/files/patch-cmake_build__configurations_compiler__options.cmake
deleted file mode 100644
index 4eca5cfb5df9..000000000000
--- a/databases/percona57-pam-for-mysql/files/patch-cmake_build__configurations_compiler__options.cmake
+++ /dev/null
@@ -1,20 +0,0 @@
---- cmake/build_configurations/compiler_options.cmake.orig 2016-08-25 11:52:06 UTC
-+++ cmake/build_configurations/compiler_options.cmake
-@@ -50,7 +50,7 @@ IF(UNIX)
- IF(CMAKE_COMPILER_IS_GNUCC)
- SET(COMMON_C_FLAGS "-fno-omit-frame-pointer -fno-strict-aliasing")
- IF(CMAKE_CXX_COMPILER_VERSION VERSION_LESS 10.0) # gcc-9 or older
-- SET(COMMON_C_FLAGS "-fabi-version=2 ${COMMON_C_FLAGS}")
-+ SET(COMMON_C_FLAGS "${COMMON_C_FLAGS}")
- ENDIF()
- # Disable inline optimizations for valgrind testing to avoid false positives
- IF(WITH_VALGRIND)
-@@ -77,7 +77,7 @@ IF(UNIX)
- IF(CMAKE_COMPILER_IS_GNUCXX)
- SET(COMMON_CXX_FLAGS "-g -fno-omit-frame-pointer -fno-strict-aliasing")
- IF(CMAKE_CXX_COMPILER_VERSION VERSION_LESS 10.0) # gcc-9 or older
-- SET(COMMON_CXX_FLAGS "-fabi-version=2 ${COMMON_CXX_FLAGS}")
-+ SET(COMMON_CXX_FLAGS "${COMMON_CXX_FLAGS}")
- ENDIF()
- # GCC 6 has C++14 as default, set it explicitly to the old default.
- EXECUTE_PROCESS(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion
diff --git a/databases/percona57-pam-for-mysql/files/patch-cmake_os_DragonFly.cmake b/databases/percona57-pam-for-mysql/files/patch-cmake_os_DragonFly.cmake
deleted file mode 100644
index 83c154ee3bcf..000000000000
--- a/databases/percona57-pam-for-mysql/files/patch-cmake_os_DragonFly.cmake
+++ /dev/null
@@ -1,27 +0,0 @@
---- cmake/os/DragonFly.cmake.orig 2016-04-14 10:16:17 UTC
-+++ cmake/os/DragonFly.cmake
-@@ -0,0 +1,24 @@
-+INCLUDE(CheckCSourceRuns)
-+
-+# We require at least GCC 4.4 or Clang 3.3.
-+IF(NOT FORCE_UNSUPPORTED_COMPILER)
-+ IF(CMAKE_COMPILER_IS_GNUCC)
-+ EXECUTE_PROCESS(COMMAND ${CMAKE_C_COMPILER} -dumpversion
-+ OUTPUT_VARIABLE GCC_VERSION)
-+ IF(GCC_VERSION VERSION_LESS 4.4)
-+ MESSAGE(FATAL_ERROR "GCC 4.4 or newer is required!")
-+ ENDIF()
-+ ELSEIF(CMAKE_C_COMPILER_ID MATCHES "Clang")
-+ CHECK_C_SOURCE_RUNS("
-+ int main()
-+ {
-+ return (__clang_major__ < 3) ||
-+ (__clang_major__ == 3 && __clang_minor__ < 3);
-+ }" HAVE_SUPPORTED_CLANG_VERSION)
-+ IF(NOT HAVE_SUPPORTED_CLANG_VERSION)
-+ MESSAGE(FATAL_ERROR "Clang 3.3 or newer is required!")
-+ ENDIF()
-+ ELSE()
-+ MESSAGE(FATAL_ERROR "Unsupported compiler!")
-+ ENDIF()
-+ENDIF()
diff --git a/databases/percona57-pam-for-mysql/files/patch-cmake_os_FreeBSD.cmake b/databases/percona57-pam-for-mysql/files/patch-cmake_os_FreeBSD.cmake
deleted file mode 100644
index 9e9043f341ae..000000000000
--- a/databases/percona57-pam-for-mysql/files/patch-cmake_os_FreeBSD.cmake
+++ /dev/null
@@ -1,25 +0,0 @@
---- cmake/os/FreeBSD.cmake.orig 2018-10-04 05:48:22 UTC
-+++ cmake/os/FreeBSD.cmake
-@@ -37,8 +37,20 @@ IF(NOT FORCE_UNSUPPORTED_COMPILER)
- IF(NOT HAVE_SUPPORTED_CLANG_VERSION)
- MESSAGE(FATAL_ERROR "Clang 3.3 or newer is required!")
- ENDIF()
-- ELSE()
-- MESSAGE(FATAL_ERROR "Unsupported compiler!")
-+ CHECK_C_SOURCE_RUNS("
-+ int main()
-+ {
-+ return (__clang_major__ >= 4);
-+ }" I386_ATOMIC_BUILTINS)
-+ IF((CMAKE_SYSTEM_PROCESSOR MATCHES "i386") AND (NOT I386_ATOMIC_BUILTINS))
-+ SET(HAVE_GCC_ATOMIC_BUILTINS CACHE INTERNAL "")
-+ ENDIF()
-+ ELSEIF(CMAKE_COMPILER_IS_GNUCC)
-+ EXECUTE_PROCESS(COMMAND ${CMAKE_C_COMPILER} -dumpversion
-+ OUTPUT_VARIABLE GCC_VERSION)
-+ IF(GCC_VERSION VERSION_LESS 4.4)
-+ MESSAGE(FATAL_ERROR "GCC 4.4 or newer is required!")
-+ ENDIF()
- ENDIF()
- ENDIF()
-
diff --git a/databases/percona57-pam-for-mysql/pkg-descr b/databases/percona57-pam-for-mysql/pkg-descr
deleted file mode 100644
index 0d2b72f09ae3..000000000000
--- a/databases/percona57-pam-for-mysql/pkg-descr
+++ /dev/null
@@ -1 +0,0 @@
-Percona PAM authentication plugin for MySQL.
diff --git a/databases/percona57-pam-for-mysql/pkg-message b/databases/percona57-pam-for-mysql/pkg-message
deleted file mode 100644
index 4bade43b0850..000000000000
--- a/databases/percona57-pam-for-mysql/pkg-message
+++ /dev/null
@@ -1,16 +0,0 @@
-[
-{ type: install
- message: <<EOM
-Documentation for using percona-pam-for-mysql authentication plugin can
-be found at:
-
-https://www.percona.com/doc/percona-pam-for-mysql/index.html
-
-Please note that you need this plugin installed on both the client and
-server for authentication to be successful.
-
-This version of the plugin is compatible with the new auth plugin API
-introduced in MySQL 5.7.
-EOM
-}
-]
diff --git a/databases/percona57-pam-for-mysql/pkg-plist b/databases/percona57-pam-for-mysql/pkg-plist
deleted file mode 100644
index 45350d3e7caf..000000000000
--- a/databases/percona57-pam-for-mysql/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@sample etc/pam.d/mysqld.sample
-lib/mysql/plugin/auth_pam.so
-lib/mysql/plugin/auth_pam_compat.so
-lib/mysql/plugin/dialog.so