aboutsummaryrefslogtreecommitdiff
path: root/databases/percona57-pam-for-mysql
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2017-01-10 18:54:32 +0000
committerMark Felder <feld@FreeBSD.org>2017-01-10 18:54:32 +0000
commitf5a7bbe20b44e2ed7ce2b3d6d9ce2e9d94056ac8 (patch)
tree9dbb8720f9319f45cd7516be53e22a9d6faa015f /databases/percona57-pam-for-mysql
parente20ec43bfc786b2390ea546eb25cae125cc1df5e (diff)
downloadports-f5a7bbe20b44e2ed7ce2b3d6d9ce2e9d94056ac8.tar.gz
ports-f5a7bbe20b44e2ed7ce2b3d6d9ce2e9d94056ac8.zip
Welcome Percona 5.7 ports to the tree
- client and server version 5.7.16-10 - pam-for-mysql: compatible with newer MySQL API (MySQL 5.7+) Thanks to all who have worked on Percona, MariaDB, and MySQL ports. Your tireless efforts have been instrumental in making this port happen. Differential Revision: https://reviews.freebsd.org/D8785
Notes
Notes: svn path=/head/; revision=431126
Diffstat (limited to 'databases/percona57-pam-for-mysql')
-rw-r--r--databases/percona57-pam-for-mysql/Makefile32
-rw-r--r--databases/percona57-pam-for-mysql/files/pam.conf12
-rw-r--r--databases/percona57-pam-for-mysql/pkg-descr3
-rw-r--r--databases/percona57-pam-for-mysql/pkg-message10
-rw-r--r--databases/percona57-pam-for-mysql/pkg-plist5
5 files changed, 62 insertions, 0 deletions
diff --git a/databases/percona57-pam-for-mysql/Makefile b/databases/percona57-pam-for-mysql/Makefile
new file mode 100644
index 000000000000..d127820061a6
--- /dev/null
+++ b/databases/percona57-pam-for-mysql/Makefile
@@ -0,0 +1,32 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= percona57
+PKGNAMESUFFIX= -pam-for-mysql
+
+COMMENT= PAM plugin for MySQL
+
+LICENSE= GPLv2+
+
+RUN_DEPENDS=# This plugin has no run dependencies. It should work with any desired mysql client/server.
+
+MASTERDIR= ${.CURDIR}/../percona57-server
+
+PKGMESSAGE= ${.CURDIR}/pkg-message
+PATCHDIR= ${MASTERDIR}/files
+FILESDIR= ${.CURDIR}/files
+PLIST= ${.CURDIR}/pkg-plist
+DESCR= ${.CURDIR}/pkg-descr
+
+CONFLICTS_INSTALL= percona5[0-68-9]-pam-for-mysql* \
+ percona-pam-for-mysql*
+
+CMAKE_ARGS+= -DWITH_PAM=1
+
+PLUGIN_ONLY= yes
+
+do-install:
+ (cd ${WRKSRC}/plugin/percona-pam-for-mysql && ${MAKE} ${MAKE_ARGS} install)
+ ${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/mysqld.sample
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/percona57-pam-for-mysql/files/pam.conf b/databases/percona57-pam-for-mysql/files/pam.conf
new file mode 100644
index 000000000000..0e75199574ba
--- /dev/null
+++ b/databases/percona57-pam-for-mysql/files/pam.conf
@@ -0,0 +1,12 @@
+#
+# PAM configuration for the "mysqld" service
+#
+
+# auth
+auth include system
+
+# account
+account include system
+
+# password
+password include system
diff --git a/databases/percona57-pam-for-mysql/pkg-descr b/databases/percona57-pam-for-mysql/pkg-descr
new file mode 100644
index 000000000000..b6160274578a
--- /dev/null
+++ b/databases/percona57-pam-for-mysql/pkg-descr
@@ -0,0 +1,3 @@
+Percona PAM authentication plugin for MySQL.
+
+WWW: https://www.percona.com/
diff --git a/databases/percona57-pam-for-mysql/pkg-message b/databases/percona57-pam-for-mysql/pkg-message
new file mode 100644
index 000000000000..6682ed7ddea3
--- /dev/null
+++ b/databases/percona57-pam-for-mysql/pkg-message
@@ -0,0 +1,10 @@
+Documentation for using percona-pam-for-mysql authentication plugin can
+be found at:
+
+https://www.percona.com/doc/percona-pam-for-mysql/index.html
+
+Please note that you need this plugin installed on both the client and
+server for authentication to be successful.
+
+This version of the plugin is compatible with the new auth plugin API
+introduced in MySQL 5.7.
diff --git a/databases/percona57-pam-for-mysql/pkg-plist b/databases/percona57-pam-for-mysql/pkg-plist
new file mode 100644
index 000000000000..3fb96a25b7bc
--- /dev/null
+++ b/databases/percona57-pam-for-mysql/pkg-plist
@@ -0,0 +1,5 @@
+@sample etc/pam.d/mysqld.sample
+lib/mysql/plugin/auth_pam.so
+lib/mysql/plugin/auth_pam_compat.so
+lib/mysql/plugin/dialog.so
+@dir lib/mysql/plugin/debug