aboutsummaryrefslogtreecommitdiff
path: root/databases/pgFormatter
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-05 13:08:12 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-05 13:08:12 +0000
commite607abfee3645777dacbb9a45c39391f71b871c1 (patch)
tree78db7fd6847da3c42f26e3c3262babe457dc5e48 /databases/pgFormatter
parenta2b3b13aa6652c0c4db0328a8bd59ceba9e597e6 (diff)
downloadports-e607abfee3645777dacbb9a45c39391f71b871c1.tar.gz
ports-e607abfee3645777dacbb9a45c39391f71b871c1.zip
New port: databases/pgFormatter
This SQL formatter/beautifier supports keywords from SQL-92, SQL-99, SQL-2003, SQL-2008, SQL-2011 and PostgreSQL specifics keywords. May works with any other databases too. pgFormatter can work as a console program or as a CGI. It will automatically detect his environment and output as text or as HTML following the context. Keywords highlighting will only be available in CGI context. WWW: https://github.com/darold/pgFormatter PR: 219681 Submitted by: Jov <amutu@amutu.com>
Notes
Notes: svn path=/head/; revision=445078
Diffstat (limited to 'databases/pgFormatter')
-rw-r--r--databases/pgFormatter/Makefile20
-rw-r--r--databases/pgFormatter/distinfo3
-rw-r--r--databases/pgFormatter/pkg-descr8
-rw-r--r--databases/pgFormatter/pkg-plist9
4 files changed, 40 insertions, 0 deletions
diff --git a/databases/pgFormatter/Makefile b/databases/pgFormatter/Makefile
new file mode 100644
index 000000000000..aaf33ffb1940
--- /dev/null
+++ b/databases/pgFormatter/Makefile
@@ -0,0 +1,20 @@
+# Created by: Jov amutu@amutu.com
+# $FreeBSD$
+
+PORTNAME= pgFormatter
+PORTVERSION= 2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+
+MAINTAINER= amutu@amutu.com
+COMMENT= PostgreSQL SQL syntax beautifier
+
+LICENSE= PostgreSQL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= perl5
+USE_PERL5= configure
+USE_GITHUB= yes
+GH_ACCOUNT= darold
+
+.include <bsd.port.mk>
diff --git a/databases/pgFormatter/distinfo b/databases/pgFormatter/distinfo
new file mode 100644
index 000000000000..7ca3590c98fb
--- /dev/null
+++ b/databases/pgFormatter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496217380
+SHA256 (darold-pgFormatter-v2.0_GH0.tar.gz) = ef2f7bc124a694c0384b6bda661582ad2dae7c25b289aba596a23fb17dd5f130
+SIZE (darold-pgFormatter-v2.0_GH0.tar.gz) = 52674
diff --git a/databases/pgFormatter/pkg-descr b/databases/pgFormatter/pkg-descr
new file mode 100644
index 000000000000..0039357e6ac2
--- /dev/null
+++ b/databases/pgFormatter/pkg-descr
@@ -0,0 +1,8 @@
+This SQL formatter/beautifier supports keywords from SQL-92, SQL-99,
+SQL-2003, SQL-2008, SQL-2011 and PostgreSQL specifics keywords. May
+works with any other databases too. pgFormatter can work as a console
+program or as a CGI. It will automatically detect his environment and
+output as text or as HTML following the context. Keywords highlighting
+will only be available in CGI context.
+
+WWW: https://github.com/darold/pgFormatter
diff --git a/databases/pgFormatter/pkg-plist b/databases/pgFormatter/pkg-plist
new file mode 100644
index 000000000000..778b4694155e
--- /dev/null
+++ b/databases/pgFormatter/pkg-plist
@@ -0,0 +1,9 @@
+bin/pg_format
+%%PERL5_MAN1%%/pg_format.1.gz
+%%PERL5_MAN3%%/pgFormatter::Beautify.3.gz
+%%PERL5_MAN3%%/pgFormatter::CGI.3.gz
+%%PERL5_MAN3%%/pgFormatter::CLI.3.gz
+%%SITE_PERL%%/pgFormatter/Beautify.pm
+%%SITE_PERL%%/pgFormatter/CGI.pm
+%%SITE_PERL%%/pgFormatter/CLI.pm
+%%SITE_PERL%%/regress_test.pl