aboutsummaryrefslogtreecommitdiff
path: root/databases/pg_dirtyread
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-27 09:19:00 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-27 09:19:00 +0000
commit10bed6ffccf263aacb1f11a774033bda46ecf2bd (patch)
tree56116053a29922f8618c23f8e0af5c8873b82567 /databases/pg_dirtyread
parent5aeaeef95dead73ee0c1ae281497c5a63142ce26 (diff)
downloadports-10bed6ffccf263aacb1f11a774033bda46ecf2bd.tar.gz
ports-10bed6ffccf263aacb1f11a774033bda46ecf2bd.zip
New port: databases/pg_dirtyread
The pg_dirtyread extension provides the ability to read dead but unvacuumed rows from a relation. WWW: https://github.com/ChristophBerg/pg_dirtyread PR: 220537 Submitted by: Jov <amutu@amutu.com>
Notes
Notes: svn path=/head/; revision=446726
Diffstat (limited to 'databases/pg_dirtyread')
-rw-r--r--databases/pg_dirtyread/Makefile27
-rw-r--r--databases/pg_dirtyread/distinfo3
-rw-r--r--databases/pg_dirtyread/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/databases/pg_dirtyread/Makefile b/databases/pg_dirtyread/Makefile
new file mode 100644
index 000000000000..fc610c86f002
--- /dev/null
+++ b/databases/pg_dirtyread/Makefile
@@ -0,0 +1,27 @@
+# Created by: Jov <amutu@amutu.com>
+# $FreeBSD$
+
+PORTNAME= pg_dirtyread
+PORTVERSION= 1.1
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= amutu@amutu.com
+COMMENT= Read dead but unvacuumed tuples from a PostgreSQL relation
+
+LICENSE= BSD3CLAUSE
+
+USES= gmake pgsql:9.2+
+USE_GITHUB= yes
+GH_ACCOUNT= ChristophBerg
+
+WANT_PGSQL= server
+
+PLIST_FILES= lib/postgresql/pg_dirtyread.so \
+ share/postgresql/extension/pg_dirtyread--1.0.sql \
+ share/postgresql/extension/pg_dirtyread.control
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pg_dirtyread.so
+
+.include <bsd.port.mk>
diff --git a/databases/pg_dirtyread/distinfo b/databases/pg_dirtyread/distinfo
new file mode 100644
index 000000000000..5c4ca050e343
--- /dev/null
+++ b/databases/pg_dirtyread/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500809216
+SHA256 (ChristophBerg-pg_dirtyread-1.1_GH0.tar.gz) = 47ea47b76b4f231d7665f22216621276d1d3387953fd2456099caecdbf2cef1f
+SIZE (ChristophBerg-pg_dirtyread-1.1_GH0.tar.gz) = 12020
diff --git a/databases/pg_dirtyread/pkg-descr b/databases/pg_dirtyread/pkg-descr
new file mode 100644
index 000000000000..68be0f83c6f7
--- /dev/null
+++ b/databases/pg_dirtyread/pkg-descr
@@ -0,0 +1,4 @@
+The pg_dirtyread extension provides the ability to read dead but unvacuumed
+rows from a relation.
+
+WWW: https://github.com/ChristophBerg/pg_dirtyread