aboutsummaryrefslogtreecommitdiff
path: root/databases/pg_reorg/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-05-29 20:21:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-05-29 20:21:45 +0000
commit188cc9c14061a7329ce6a2fe7d68ee3145ef3510 (patch)
tree9b396ad7fb8b073ff3f3224b0c51f16806531b3a /databases/pg_reorg/Makefile
parent9951638e48bbb7051abcd018150645df357ae781 (diff)
downloadports-188cc9c14061a7329ce6a2fe7d68ee3145ef3510.tar.gz
ports-188cc9c14061a7329ce6a2fe7d68ee3145ef3510.zip
- Fix build
- Fix plist with pgsql > 9.0 - Update to 1.1.10 to fix with pgsql >= 9.3 Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=355744
Diffstat (limited to 'databases/pg_reorg/Makefile')
-rw-r--r--databases/pg_reorg/Makefile33
1 files changed, 22 insertions, 11 deletions
diff --git a/databases/pg_reorg/Makefile b/databases/pg_reorg/Makefile
index a016101e11f2..6515e7082845 100644
--- a/databases/pg_reorg/Makefile
+++ b/databases/pg_reorg/Makefile
@@ -2,24 +2,22 @@
# $FreeBSD$
PORTNAME= pg_reorg
-PORTVERSION= 1.1.8
+PORTVERSION= 1.1.10
CATEGORIES= databases
-MASTER_SITES= http://pgfoundry.org/frs/download.php/3395/
+MASTER_SITES= http://pgfoundry.org/frs/download.php/3644/
MAINTAINER= ports@FreeBSD.org
COMMENT= PostgreSQL utility to reorganize tables
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
MAKE_ENV= USE_PGXS=0
-USES= gmake pgsql
+USES= gmake pgsql uidfix
+WANT_PGSQL=server
+
+PLIST_FILES= bin/pg_reorg lib/postgresql/pg_reorg.so
-PLIST_FILES= bin/pg_reorg \
- lib/postgresql/pg_reorg.so \
- share/postgresql/contrib/pg_reorg--1.1.8.sql \
- share/postgresql/contrib/pg_reorg.sql \
- share/postgresql/contrib/uninstall_pg_reorg.sql
-PLIST_DIRSTRY= share/postgresql/contrib
PORTDOCS= *
OPTIONS_DEFINE= DOCS
@@ -28,4 +26,17 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PGSQL_VER} >= 9.1
+PLIST_FILES+= share/postgresql/extension/pg_reorg--1.1.10.sql \
+ share/postgresql/extension/pg_reorg.control \
+ share/postgresql/extension/pg_reorg.sql \
+ share/postgresql/extension/uninstall_pg_reorg.sql
+.else
+PLIST_FILES+= share/postgresql/contrib/pg_reorg--1.1.8.sql \
+ share/postgresql/contrib/pg_reorg.sql \
+ share/postgresql/contrib/uninstall_pg_reorg.sql
+.endif
+
+.include <bsd.port.post.mk>