aboutsummaryrefslogtreecommitdiff
path: root/databases/pg_reorg
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-08-03 09:02:38 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-08-03 09:02:38 +0000
commit3b468649228589db4b1c126bcf0b9d34295a3bf5 (patch)
treef861cc2fc81ed1144e2180e13cdea42fad0f6796 /databases/pg_reorg
parenta946e50d48cc0d78e4a4c0df76188becea69127d (diff)
downloadports-3b468649228589db4b1c126bcf0b9d34295a3bf5.tar.gz
ports-3b468649228589db4b1c126bcf0b9d34295a3bf5.zip
databases/pg_reorg: Do not build on newer PostgreSQL versions
It fails to build with PostgreSQL 11: pgut/pgut.c:389:47: error: too few arguments to function call, expected 4, have 3 return simple_prompt("Password: ", 100, false); ~~~~~~~~~~~~~ ^ /usr/local/include/postgresql/server/port.h:193:1: note: 'simple_prompt' declared here extern void simple_prompt(const char *prompt, char *destination, size_t destlen, ^ 1 error generated. http://package18.nyi.freebsd.org/data/120amd64-default-PR239514/2019-07-29_20h41m52s/logs/pg_reorg-1.1.11_2.log And after fixing that one: reorg.c:230:55: warning: incompatible pointer types passing 'bool [1]' to parameter of type 'const char *' [-Wincompatible-pointer-types] execute_plan(SPI_OK_SELECT, plan_peek, values_peek, nulls_peek); ^~~~~~~~~~ ./pgut/pgut-spi.h:28:84: note: passing argument to parameter 'nulls' here extern void execute_plan(int expected, SPIPlanPtr plan, Datum *values, const char *nulls); ^ reorg.c:256:58: warning: incompatible pointer types passing 'bool *' to parameter of type 'const char *' [-Wincompatible-pointer-types] execute_plan(SPI_OK_INSERT, plan_insert, &values[2], &nulls[2]); ^~~~~~~~~ [...] reorg.c:573:34: error: use of undeclared identifier 'BTREE_AM_OID' opclass = OpclassnameGetOpcid(BTREE_AM_OID, opcname); ^ reorg.c:590:57: error: member reference type 'FormData_pg_attribute' (aka 'struct FormData_pg_attribute') is not a pointer; did you mean to use '.'? opcintype = RelationGetDescr(indexRel)->attrs[nattr]->atttypid; ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~ etc. PR: 239514
Notes
Notes: svn path=/head/; revision=507940
Diffstat (limited to 'databases/pg_reorg')
-rw-r--r--databases/pg_reorg/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/databases/pg_reorg/Makefile b/databases/pg_reorg/Makefile
index b7f1fe9aaefe..1e95b1b33f6f 100644
--- a/databases/pg_reorg/Makefile
+++ b/databases/pg_reorg/Makefile
@@ -24,8 +24,14 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${PGSQL_VER:R} >= 11
+IGNORE= incompatible with PostgreSQL 11 or newer
+.endif
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>