aboutsummaryrefslogtreecommitdiff
path: root/databases/pg_similarity
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-07-28 14:57:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-07-28 14:57:52 +0000
commit8636387023a00bc4f5d3c371aa088edcaa4989ff (patch)
treed5db8bac6e939116800602329fa0cad98faf8636 /databases/pg_similarity
parent91e39612ba66d74d722e42dc1e65e5936ae5874a (diff)
downloadports-8636387023a00bc4f5d3c371aa088edcaa4989ff.tar.gz
ports-8636387023a00bc4f5d3c371aa088edcaa4989ff.zip
pg_similarity is an extension to support similarity queries on PostgreSQL. The
implementation is tightly integrated in the RDBMS in the sense that it defines operators so instead of the traditional operators (= and <>) you can use ~~~ and ! (any of these operators represents a similarity function). pg_similarity has three main components: * Functions: a set of functions that implements similarity algorithms available in the literature. These functions can be used as UDFs and, will be the base for implementing the similarity operators; * Operators: a set of operators defined at the top of similarity functions. They use similarity functions to obtain the similarity threshold and, compare its value to a user-defined threshold to decide if it is a match or not; * Session Variables: a set of variables that store similarity function parameters. Theses variables can be defined at run time. WWW: http://pgsimilarity.projects.pgfoundry.org PR: 220428 Submitted by: Jov <amutu@amutu.com> Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=475583
Diffstat (limited to 'databases/pg_similarity')
-rw-r--r--databases/pg_similarity/Makefile32
-rw-r--r--databases/pg_similarity/distinfo3
-rw-r--r--databases/pg_similarity/pkg-descr17
3 files changed, 52 insertions, 0 deletions
diff --git a/databases/pg_similarity/Makefile b/databases/pg_similarity/Makefile
new file mode 100644
index 000000000000..9ed6daeb92c8
--- /dev/null
+++ b/databases/pg_similarity/Makefile
@@ -0,0 +1,32 @@
+# Created by: Jov <amutu@amutu.com>
+# $FreeBSD$
+
+PORTNAME= pg_similarity
+PORTVERSION= 20160917
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= amutu@amutu.com
+COMMENT= Set of functions and operators for executing similarity queries
+
+LICENSE= BSD3CLAUSE
+
+USES= gmake pgsql:9.1+
+USE_GITHUB= yes
+GH_ACCOUNT= eulerto
+GH_TAGNAME= be1a8b0
+
+MAKE_ENV= USE_PGXS=1
+
+WANT_PGSQL= server
+
+PLIST_FILES= lib/postgresql/pg_similarity.so \
+ share/postgresql/extension/pg_similarity--1.0.sql \
+ share/postgresql/extension/pg_similarity--unpackaged--1.0.sql \
+ share/postgresql/extension/pg_similarity.control \
+ share/postgresql/extension/pg_similarity.sql
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pg_similarity.so
+
+.include <bsd.port.mk>
diff --git a/databases/pg_similarity/distinfo b/databases/pg_similarity/distinfo
new file mode 100644
index 000000000000..7f3a5d3c4f4c
--- /dev/null
+++ b/databases/pg_similarity/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498975894
+SHA256 (eulerto-pg_similarity-20160917-be1a8b0_GH0.tar.gz) = 6c990a211c6bc9f477fd401f5ecce102743b3e4811db73c233cdc79cc187ace9
+SIZE (eulerto-pg_similarity-20160917-be1a8b0_GH0.tar.gz) = 57627
diff --git a/databases/pg_similarity/pkg-descr b/databases/pg_similarity/pkg-descr
new file mode 100644
index 000000000000..a10bad66a970
--- /dev/null
+++ b/databases/pg_similarity/pkg-descr
@@ -0,0 +1,17 @@
+pg_similarity is an extension to support similarity queries on PostgreSQL. The
+implementation is tightly integrated in the RDBMS in the sense that it defines
+operators so instead of the traditional operators (= and <>) you can use ~~~
+and ! (any of these operators represents a similarity function).
+
+pg_similarity has three main components:
+
+* Functions: a set of functions that implements similarity algorithms available
+ in the literature. These functions can be used as UDFs and, will be the base
+ for implementing the similarity operators;
+* Operators: a set of operators defined at the top of similarity functions. They
+ use similarity functions to obtain the similarity threshold and, compare its
+ value to a user-defined threshold to decide if it is a match or not;
+* Session Variables: a set of variables that store similarity function
+ parameters. Theses variables can be defined at run time.
+
+WWW: http://pgsimilarity.projects.pgfoundry.org