aboutsummaryrefslogtreecommitdiff
path: root/databases/pgaccess
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-09-06 09:27:24 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-09-06 09:27:24 +0000
commit18e51b603d3c6521ba24b2878a65bf5ddc2a9714 (patch)
treedf8f2929a93cbe2dfcdfcec6db97d1ac67ced603 /databases/pgaccess
parent37b9644ed34c60ff74340493ab7774dc942a308e (diff)
downloadports-18e51b603d3c6521ba24b2878a65bf5ddc2a9714.tar.gz
ports-18e51b603d3c6521ba24b2878a65bf5ddc2a9714.zip
- Update to new upstream version 1.00.20140902
- Assign maintainership to Chris Hutchinson <portmaster@bsdforge.com> - Cleanup Makefile, update pkg-descr - Stagify - Remove EXPIRATION_DATE PR: 193046 Submitted by: portmaster@bsdforge.com Reviewed by: riggs
Notes
Notes: svn path=/head/; revision=367409
Diffstat (limited to 'databases/pgaccess')
-rw-r--r--databases/pgaccess/Makefile45
-rw-r--r--databases/pgaccess/distinfo4
-rw-r--r--databases/pgaccess/files/run-tcl-file2
-rw-r--r--databases/pgaccess/pkg-descr20
-rw-r--r--databases/pgaccess/pkg-plist14
5 files changed, 39 insertions, 46 deletions
diff --git a/databases/pgaccess/Makefile b/databases/pgaccess/Makefile
index c49972260e26..65dd25b297de 100644
--- a/databases/pgaccess/Makefile
+++ b/databases/pgaccess/Makefile
@@ -2,31 +2,28 @@
# $FreeBSD$
PORTNAME= pgaccess
-PORTVERSION= 0.99.0.20040219
-PORTREVISION= 3
+PORTVERSION= 1.00.20140902
CATEGORIES= databases tcl tk
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://bsdforge.com/projects/source/databases/pgaccess/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Powerful GUI PostgreSQL database administration tool and toolkit
+MAINTAINER= portmaster@bsdforge.com
+COMMENT= Powerful PostgreSQL database GUI administration tool and toolkit
-DEPRECATED= not maintained upstreams for ten years
-EXPIRATION_DATE=2014-08-31
+LICENSE= BSD4CLAUSE
-BUILD_DEPENDS+= ${RUN_DEPENDS}
RUN_DEPENDS= ${LOCALBASE}/lib/pgtcl/pkgIndex.tcl:${PORTSDIR}/databases/pgtcl
-USE_PGSQL= server:extract
+USES= pgsql tk:84+ tar:xz
+
+NO_ARCH= yes
-TCLVERSION?= 8.4
DOCSDIR= ${PREFIX}/share/doc/postgresql/${PORTNAME}
PGACCESSDIR= ${PREFIX}/share/postgresql/${PORTNAME}
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e "s,/usr/bin,${PREFIX}/bin,g ; " ${WRKSRC}/lib/mainlib.tcl
@${RM} ${WRKSRC}/lib/mainlib.tcl.bak
@@ -34,25 +31,23 @@ post-patch:
do-build:
.for targetfile in pgaccess.tcl pgmonitor
@ ${SED} -e "s,%%LOCALBASE%%,${LOCALBASE},g; \
- s,%%TCL_VERSION%%,${TCLVERSION},g; \
+ s,%%WISH%%,${WISH},g; \
s,%%PREFIX%%,${PREFIX},g; \
s,%%PROGRAM%%,${targetfile},g" \
< ${FILESDIR}/run-tcl-file > ${WRKDIR}/${targetfile:R}.sh
.endfor
do-install:
- @${MKDIR} ${PGACCESSDIR} ; \
- cd ${WRKSRC} ;\
- ${TAR} cf - `${FIND} * ! \( -path win32\* -o -path doc\* \)` | \
- ( cd ${PGACCESSDIR}; ${TAR} xf - ) ; \
- ${CHOWN} -R 0:0 ${PGACCESSDIR}
+ @${MKDIR} ${STAGEDIR}${PGACCESSDIR} ; \
+ cd ${WRKSRC} ;\
+ ${TAR} cf - `${FIND} * ! \( -path win32\* -o -path doc\* \)` | \
+ ( cd ${STAGEDIR}${PGACCESSDIR}; ${TAR} xf - )
.for targetfile in pgaccess pgmonitor
- ${INSTALL_SCRIPT} ${WRKDIR}/${targetfile}.sh ${PREFIX}/bin/${targetfile}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${targetfile}.sh ${STAGEDIR}${PREFIX}/bin/${targetfile}
.endfor
- @${MKDIR} ${DOCSDIR} ; \
- cd ${WRKSRC}/doc/html ;\
- ${TAR} cf - * | \
- ( cd ${DOCSDIR}; ${TAR} xf - ) ; \
- ${CHOWN} -R 0:0 ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ; \
+ cd ${WRKSRC}/doc/html ;\
+ ${TAR} cf - * | \
+ ( cd ${STAGEDIR}${DOCSDIR}; ${TAR} xf - )
.include <bsd.port.mk>
diff --git a/databases/pgaccess/distinfo b/databases/pgaccess/distinfo
index 399de6d679c1..4ea3a7584427 100644
--- a/databases/pgaccess/distinfo
+++ b/databases/pgaccess/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pgaccess-0_99_0_20040219.tgz) = 26eb9edd450b069f0b8a044f34fbacbbcb9dd135e7fc96701cd3d2520eded7a9
-SIZE (pgaccess-0_99_0_20040219.tgz) = 1457184
+SHA256 (pgaccess-1.00.20140902.tar.xz) = b024e651f28533bdb04bdc4c2f908be4860cce080f5aa18e0f91677ef936b65a
+SIZE (pgaccess-1.00.20140902.tar.xz) = 1094440
diff --git a/databases/pgaccess/files/run-tcl-file b/databases/pgaccess/files/run-tcl-file
index 8b5b563b3648..51a7cb47a2c9 100644
--- a/databases/pgaccess/files/run-tcl-file
+++ b/databases/pgaccess/files/run-tcl-file
@@ -1,6 +1,6 @@
#!/bin/sh
-PATH_TO_WISH='%%LOCALBASE%%/bin/wish%%TCL_VERSION%%'
+PATH_TO_WISH='%%WISH%%'
PGACCESS_HOME='%%PREFIX%%/share/postgresql/pgaccess'
PGLIB='%%LOCALBASE%%/lib'
PGPORT="${PGPORT:-5432}"
diff --git a/databases/pgaccess/pkg-descr b/databases/pgaccess/pkg-descr
index 2a85fd7fbd89..ff963ff7b825 100644
--- a/databases/pgaccess/pkg-descr
+++ b/databases/pgaccess/pkg-descr
@@ -1,13 +1,13 @@
-PgAccess is one of the prettiest GUIs (graphical user interfaces) for
-the open source database PostgreSQL.
+PgAccess is a pretty GUI (Griphical User Interface) for the open source
+database PostgreSQL.
-PgAccess is a cross-platform database management tool for PostgreSQL
-written in Tcl/Tk. There are active efforts to turn it into a tool for
-writing applications that can work in a distributed client-server
-model (a central PostgreSQL database and remote clients).
+PgAccess is a cross-platform database management tool for PostgreSQL, written in
+Tcl/Tk. There are active efforts to turn it into a tool for writing applications
+that can work in a distributed client-server model (a central PostgreSQL
+database and remote clients).
-PgAccess was originally written by Constantin Teodorescu using Visual
-Tcl, "the best tool for developing Tcl/Tk applications I've ever
-seen." It is currently managed by a growing team of developers.
+PgAccess was originally written by Constantin Teodorescu using Visual Tcl,
+"the best tool for developing Tcl/Tk applications I've ever seen."
+It is currently managed by hte developers at BSDforge.com.
-WWW: http://sourceforge.net/projects/pgaccess/
+WWW: http://BSDforge.com/projects/databases/pgaccess/
diff --git a/databases/pgaccess/pkg-plist b/databases/pgaccess/pkg-plist
index 49f27e2ce48c..7cee619e1073 100644
--- a/databases/pgaccess/pkg-plist
+++ b/databases/pgaccess/pkg-plist
@@ -56,8 +56,8 @@ bin/pgmonitor
%%PORTDOCS%%%%DOCSDIR%%/win32.html
share/postgresql/pgaccess/Makefile
share/postgresql/pgaccess/README
-share/postgresql/pgaccess/changelog
-share/postgresql/pgaccess/copyright
+share/postgresql/pgaccess/CHANGELOG
+share/postgresql/pgaccess/LICENSE
share/postgresql/pgaccess/demo/README.demo
share/postgresql/pgaccess/demo/demo.pga
share/postgresql/pgaccess/demo/formdemo72.sql
@@ -88,7 +88,7 @@ share/postgresql/pgaccess/images/icon_table.gif
share/postgresql/pgaccess/images/icon_text.gif
share/postgresql/pgaccess/images/icon_tree.gif
share/postgresql/pgaccess/images/logo.gif
-share/postgresql/pgaccess/known_bugs
+share/postgresql/pgaccess/BUGS
share/postgresql/pgaccess/lib/aggregates.tcl
share/postgresql/pgaccess/lib/casts.tcl
share/postgresql/pgaccess/lib/colors.tcl
@@ -365,7 +365,7 @@ share/postgresql/pgaccess/osx/README.osx
share/postgresql/pgaccess/osx/dylib/libpgtcl.7.3.dylib.sit
share/postgresql/pgaccess/pgaccess.tcl
share/postgresql/pgaccess/pgmonitor
-share/postgresql/pgaccess/todo
+share/postgresql/pgaccess/TODO
share/postgresql/pgaccess/utils/mkkit.tcl
@dirrm share/postgresql/pgaccess/utils
@dirrm share/postgresql/pgaccess/osx/dylib
@@ -391,7 +391,5 @@ share/postgresql/pgaccess/utils/mkkit.tcl
@dirrm share/postgresql/pgaccess/extra
@dirrm share/postgresql/pgaccess/demo
@dirrm share/postgresql/pgaccess
-@dirrmtry share/postgresql
-%%PORTDOCS%%@dirrm share/doc/postgresql/pgaccess/tutorial
-%%PORTDOCS%%@dirrm share/doc/postgresql/pgaccess
-%%PORTDOCS%%@dirrmtry share/doc/postgresql
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tutorial
+%%PORTDOCS%%@dirrm %%DOCSDIR%%