aboutsummaryrefslogtreecommitdiff
path: root/databases/pgadmin3/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-02-23 19:28:13 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-02-23 19:28:13 +0000
commitdc0eeebdd19b46e8b6fa23a076dc76dd7c1f205f (patch)
treee07f01e9167a4cee7a8d40a00608a706449fad5a /databases/pgadmin3/Makefile
parent571a68503131d4037ff08ba7c9dc5b9603e87b5f (diff)
downloadports-dc0eeebdd19b46e8b6fa23a076dc76dd7c1f205f.tar.gz
ports-dc0eeebdd19b46e8b6fa23a076dc76dd7c1f205f.zip
Notes
Diffstat (limited to 'databases/pgadmin3/Makefile')
-rw-r--r--databases/pgadmin3/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index 2dd649ad03fc..2b8e404b505e 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pgadmin3
PORTVERSION= 1.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= pgadmin3/release/v${PORTVERSION}/src
@@ -15,13 +15,10 @@ MASTER_SITE_SUBDIR= pgadmin3/release/v${PORTVERSION}/src
MAINTAINER= fjoe@FreeBSD.org
COMMENT= PostgreSQL database design and management system
-LIB_DEPENDS+= wx_gtk2u_stc-2.5.3:${PORTSDIR}/x11-toolkits/wxgtk2-unicode-contrib-devel
-
USE_PGSQL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-wx=${X11BASE}\
- --with-wx-config=wxgtk2u-2.5-config
+CONFIGURE_ARGS= --with-wx=${X11BASE}
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LIBS="${PTHREAD_LIBS}"
@@ -31,7 +28,22 @@ post-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-IGNORE= Systems prior to FreeBSD 5.0 currently out of support
+WITHOUT_UNICODE= yes
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_UNICODE)
+ @${ECHO_MSG} "You can build non-Unicode version by defining WITHOUT_UNICODE."
.endif
+.if !defined(WITHOUT_UNICODE)
+LIB_DEPENDS+= wx_gtk2u_stc-2.5.3:${PORTSDIR}/x11-toolkits/wxgtk2-unicode-contrib-devel
+CONFIGURE_ARGS+=--with-wx-config=wxgtk2u-2.5-config
+PKGNAMESUFFIX= -unicode
+PKGMESSAGE= ${PKGDIR}/pkg-message-unicode
+.else
+LIB_DEPENDS+= wx_gtk2_stc-2.5.3:${PORTSDIR}/x11-toolkits/wxgtk2-contrib-devel
+CONFIGURE_ARGS+=--with-wx-config=wxgtk2-2.5-config
+.endif # WITHOUT_UNICODE
+
.include <bsd.port.post.mk>