aboutsummaryrefslogtreecommitdiff
path: root/databases/pgbarman
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-12-02 15:41:14 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-12-02 15:41:14 +0000
commit08e16cd8b282f09f97c798f090d28a7c54662734 (patch)
treedfd3a37f2aa5726aeab2e13a62b961ee02d3b197 /databases/pgbarman
parent0f1c879e37ddb0d10e494ba112c8f77e320b927a (diff)
downloadports-08e16cd8b282f09f97c798f090d28a7c54662734.tar.gz
ports-08e16cd8b282f09f97c798f090d28a7c54662734.zip
New port:
Barman: backup and recovery manager for PostgreSQL. Barman is an open-source administration tool for disaster recovery of PostgreSQL servers written in Python. It allows your organisation to perform remote backups of multiple servers in business critical environments and helps DBAs during the recovery phase. WWW: http://www.pgbarman.org/
Notes
Notes: svn path=/head/; revision=373768
Diffstat (limited to 'databases/pgbarman')
-rw-r--r--databases/pgbarman/Makefile43
-rw-r--r--databases/pgbarman/distinfo4
-rw-r--r--databases/pgbarman/files/patch-barman_config.py13
-rw-r--r--databases/pgbarman/pkg-descr11
-rw-r--r--databases/pgbarman/pkg-plist1
5 files changed, 72 insertions, 0 deletions
diff --git a/databases/pgbarman/Makefile b/databases/pgbarman/Makefile
new file mode 100644
index 000000000000..89ca38b12233
--- /dev/null
+++ b/databases/pgbarman/Makefile
@@ -0,0 +1,43 @@
+# Created by: MAtthew Seaman
+# $FreeBSD$
+
+PORTNAME= barman
+DISTVERSION= 1.3.3
+CATEGORIES= databases
+MASTER_SITES= SF/${PKGNAMEPREFIX}${PORTNAME}/${DISTVERSION}
+PKGNAMEPREFIX= pg
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} barman-tutorial.en.pdf
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Backup and recovery manager for PostgreSQL
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync \
+ ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2 \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.1:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}argh>0:${PORTSDIR}/devel/py-argh
+
+USERS= barman
+GROUPS= barman
+
+USES= python pgsql
+WANT_PGSQL= client
+USE_PYTHON= autoplist distutils
+
+PORTDOCS= barman-tutorial.en.pdf
+
+post-extract:
+ ${CP} ${DISTDIR}/${PORTDOCS} ${WRKDIR}/
+
+post-patch:
+ ${SED} -i -e "s@%%PREFIX%%@${PREFIX}@" ${WRKSRC}/barman/config.py
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/barman.conf ${STAGEDIR}${ETCDIR}/barman.conf.sample
+
+.include <bsd.port.mk>
diff --git a/databases/pgbarman/distinfo b/databases/pgbarman/distinfo
new file mode 100644
index 000000000000..78e551203710
--- /dev/null
+++ b/databases/pgbarman/distinfo
@@ -0,0 +1,4 @@
+SHA256 (barman-1.3.3.tar.gz) = 3e3af2fec16ac2836965a4c135d9ef4959ed690fb40ef06571d03ff526448468
+SIZE (barman-1.3.3.tar.gz) = 111462
+SHA256 (barman-tutorial.en.pdf) = f05666353ba61d8faeed70fcb32a6bc46fa4450dce6af9df462c2efeffad6734
+SIZE (barman-tutorial.en.pdf) = 276813
diff --git a/databases/pgbarman/files/patch-barman_config.py b/databases/pgbarman/files/patch-barman_config.py
new file mode 100644
index 000000000000..b460dd23ad4c
--- /dev/null
+++ b/databases/pgbarman/files/patch-barman_config.py
@@ -0,0 +1,13 @@
+--- barman/config.py.orig 2014-12-02 14:47:11 UTC
++++ barman/config.py
+@@ -341,8 +341,8 @@ class Config(object):
+ """
+ CONFIG_FILES = [
+ '~/.barman.conf',
+- '/etc/barman.conf',
+- '/etc/barman/barman.conf',
++ '%%PREFIX%%/etc/barman.conf',
++ '%%PREFIX%%/etc/barman/barman.conf',
+ ]
+
+ _QUOTE_RE = re.compile(r"""^(["'])(.*)\1$""")
diff --git a/databases/pgbarman/pkg-descr b/databases/pgbarman/pkg-descr
new file mode 100644
index 000000000000..993918f101e1
--- /dev/null
+++ b/databases/pgbarman/pkg-descr
@@ -0,0 +1,11 @@
+
+Barman: backup and recovery manager for PostgreSQL.
+
+Barman is an open-source administration tool for disaster recovery of
+PostgreSQL servers written in Python.
+
+It allows your organisation to perform remote backups of multiple
+servers in business critical environments and helps DBAs during the
+recovery phase.
+
+WWW: http://www.pgbarman.org/
diff --git a/databases/pgbarman/pkg-plist b/databases/pgbarman/pkg-plist
new file mode 100644
index 000000000000..008e9fcb1919
--- /dev/null
+++ b/databases/pgbarman/pkg-plist
@@ -0,0 +1 @@
+@sample %%ETCDIR%%/barman.conf.sample