aboutsummaryrefslogtreecommitdiff
path: root/databases/pgbouncer
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2012-07-01 08:50:48 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2012-07-01 08:50:48 +0000
commit93da9d017344d9518cfe3cf878984e2979933546 (patch)
tree46f1b305a331a43654131369f64cf2152656377f /databases/pgbouncer
parent0e6c83afe5dc9a1cd85795f71fa1db4874cc71b3 (diff)
downloadports-93da9d017344d9518cfe3cf878984e2979933546.tar.gz
ports-93da9d017344d9518cfe3cf878984e2979933546.zip
* Update to 1.5.2 [1]
* Add patch to use TCP_KEEP{CNT, IDLE, INTVL, ALIVE} [2] Changes: http://pgfoundry.org/forum/forum.php?forum_id=1885 PR: ports/169463 [1] Submitted by: Dmitry <dmitry2004@yandex.ru> [1], Oleg A. Mamontov <oleg@mamontov.net> [2]
Notes
Notes: svn path=/head/; revision=300308
Diffstat (limited to 'databases/pgbouncer')
-rw-r--r--databases/pgbouncer/Makefile4
-rw-r--r--databases/pgbouncer/distinfo4
-rw-r--r--databases/pgbouncer/files/patch-keepalive46
-rw-r--r--databases/pgbouncer/pkg-descr2
4 files changed, 51 insertions, 5 deletions
diff --git a/databases/pgbouncer/Makefile b/databases/pgbouncer/Makefile
index ae0a43e73874..38a8e3009a5d 100644
--- a/databases/pgbouncer/Makefile
+++ b/databases/pgbouncer/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= pgbouncer
-PORTVERSION= 1.5.1
+PORTVERSION= 1.5.2
CATEGORIES= databases
-MASTER_SITES= http://pgfoundry.org/frs/download.php/3240/
+MASTER_SITES= http://pgfoundry.org/frs/download.php/3293/
MAINTAINER= skv@FreeBSD.org
COMMENT= Lightweight connection pooler for PostgreSQL
diff --git a/databases/pgbouncer/distinfo b/databases/pgbouncer/distinfo
index 08fea9ca0deb..7bde26bd5859 100644
--- a/databases/pgbouncer/distinfo
+++ b/databases/pgbouncer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pgbouncer-1.5.1.tar.gz) = d0634253d319e43ebc18cb0476ba28c47803eff5bae5c6e17f650dc031fc4434
-SIZE (pgbouncer-1.5.1.tar.gz) = 334413
+SHA256 (pgbouncer-1.5.2.tar.gz) = f17ebf1dfe34dd4c39c2dd861d5b58f08cecef22be3b74da256d25ea15d451f8
+SIZE (pgbouncer-1.5.2.tar.gz) = 335338
diff --git a/databases/pgbouncer/files/patch-keepalive b/databases/pgbouncer/files/patch-keepalive
new file mode 100644
index 000000000000..5da439c89796
--- /dev/null
+++ b/databases/pgbouncer/files/patch-keepalive
@@ -0,0 +1,46 @@
+--- src/util.c.orig 2011-12-07 15:04:13.000000000 +0400
++++ src/util.c 2011-12-07 15:04:07.000000000 +0400
+@@ -126,7 +126,7 @@
+ res = setsockopt(sock, SOL_SOCKET, SO_KEEPALIVE, &val, sizeof(val));
+ if (res < 0)
+ goto fail;
+-#ifdef __linux__
++#ifdef TCP_KEEPCNT
+ /* set count of keepalive packets */
+ if (cf_tcp_keepcnt > 0) {
+ val = cf_tcp_keepcnt;
+@@ -134,6 +134,8 @@
+ if (res < 0)
+ goto fail;
+ }
++#endif
++#ifdef TCP_KEEPIDLE
+ /* how long the connection can stay idle before sending keepalive pkts */
+ if (cf_tcp_keepidle) {
+ val = cf_tcp_keepidle;
+@@ -141,6 +143,8 @@
+ if (res < 0)
+ goto fail;
+ }
++#endif
++#ifdef TCP_KEEPINTVL
+ /* time between packets */
+ if (cf_tcp_keepintvl) {
+ val = cf_tcp_keepintvl;
+@@ -148,7 +152,7 @@
+ if (res < 0)
+ goto fail;
+ }
+-#else
++#endif
+ #ifdef TCP_KEEPALIVE
+ if (cf_tcp_keepidle) {
+ val = cf_tcp_keepidle;
+@@ -157,7 +161,6 @@
+ goto fail;
+ }
+ #endif
+-#endif
+ }
+
+ /* set in-kernel socket buffer size */
diff --git a/databases/pgbouncer/pkg-descr b/databases/pgbouncer/pkg-descr
index ef1d0fc95bf9..3909676ffdf8 100644
--- a/databases/pgbouncer/pkg-descr
+++ b/databases/pgbouncer/pkg-descr
@@ -1,3 +1,3 @@
Lightweight connection pooler for PostgreSQL.
-WWW: https://developer.skype.com/SkypeGarage/DbProjects/PgBouncer
+WWW: http://pgfoundry.org/projects/pgbouncer/