aboutsummaryrefslogtreecommitdiff
path: root/databases/pgespresso
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-05-23 10:30:09 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-05-23 10:30:09 +0000
commit754df4ebfa77d8eec69b3d68ea3bb18e49c33527 (patch)
treeafdfac406e219c355b5b19f50cac8fb948ee243e /databases/pgespresso
parentdb527ddf9d5328f6f59121f89bc1d177cf9e9026 (diff)
downloadports-754df4ebfa77d8eec69b3d68ea3bb18e49c33527.tar.gz
ports-754df4ebfa77d8eec69b3d68ea3bb18e49c33527.zip
Update to version 1.1
- Remove patch as this has been incorporated upstream. Release 1.1 is functionally identical to the previous 1.0 port + patch. ChangeLog: https://github.com/2ndquadrant-it/pgespresso/blob/master/ChangeLog
Notes
Notes: svn path=/head/; revision=415712
Diffstat (limited to 'databases/pgespresso')
-rw-r--r--databases/pgespresso/Makefile3
-rw-r--r--databases/pgespresso/distinfo5
-rw-r--r--databases/pgespresso/files/patch-pgespresso.c42
3 files changed, 4 insertions, 46 deletions
diff --git a/databases/pgespresso/Makefile b/databases/pgespresso/Makefile
index 480ce1482b5e..c56176b76aea 100644
--- a/databases/pgespresso/Makefile
+++ b/databases/pgespresso/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pgespresso
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.1
CATEGORIES= databases
MAINTAINER= matthew@FreeBSD.org
diff --git a/databases/pgespresso/distinfo b/databases/pgespresso/distinfo
index 25b4cf861125..12c6b73532b5 100644
--- a/databases/pgespresso/distinfo
+++ b/databases/pgespresso/distinfo
@@ -1,2 +1,3 @@
-SHA256 (2ndquadrant-it-pgespresso-1.0_GH0.tar.gz) = c6a0fbbe421d762b3e17934fe61649420744639f2b032844a81699121d0dfb31
-SIZE (2ndquadrant-it-pgespresso-1.0_GH0.tar.gz) = 9469
+TIMESTAMP = 1463999096
+SHA256 (2ndquadrant-it-pgespresso-1.1_GH0.tar.gz) = a43895dc282fd0060e079877ba0f0a7c8e8ca33b60bb47f323a0ff8adc774ebf
+SIZE (2ndquadrant-it-pgespresso-1.1_GH0.tar.gz) = 9980
diff --git a/databases/pgespresso/files/patch-pgespresso.c b/databases/pgespresso/files/patch-pgespresso.c
deleted file mode 100644
index 795e4e7339cd..000000000000
--- a/databases/pgespresso/files/patch-pgespresso.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- pgespresso.c.orig 2014-04-11 10:46:36 UTC
-+++ pgespresso.c
-@@ -78,10 +78,38 @@ pgespresso_start_backup(PG_FUNCTION_ARGS
- }
-
- /*
-+ * Starting from 9.5 the do_pg_start_backup caller needs to allocate the
-+ * 'pg_tblspc' directory and pass it as argument.
-+ *
-+ * Ref: http://git.postgresql.org/gitweb/?p=postgresql.git;h=72d422a
-+ */
-+ #if PG_VERSION_NUM >= 90500
-+ {
-+ DIR *dir;
-+
-+ /* Make sure we can open the directory with
-+ tablespaces in it */
-+ dir = AllocateDir("pg_tblspc");
-+
-+ if (!dir)
-+ ereport(ERROR,
-+ (errmsg("could not open directory \"%s\": %m", "pg_tblspc")));
-+
-+ /*
-+ * We are not filling the tablespace map here.
-+ * This means that on 9.5 the 'tablespace_map' file has to be
-+ * generated by the invoker.
-+ */
-+ do_pg_start_backup(backupidstr, fast, NULL, &labelfile,
-+ dir, NULL, NULL, false, false);
-+
-+ FreeDir(dir);
-+ }
-+ /*
- * Starting from 9.3 the do_pg_start_backup returns the timeline ID
- * in *starttli_p additional argument
- */
-- #if PG_VERSION_NUM >= 90300
-+ #elif PG_VERSION_NUM >= 90300
- do_pg_start_backup(backupidstr, fast, NULL, &labelfile);
- #else
- do_pg_start_backup(backupidstr, fast, &labelfile);