aboutsummaryrefslogtreecommitdiff
path: root/databases/pglogical
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2019-03-06 06:53:54 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2019-03-06 06:53:54 +0000
commitfc02e3fd431a0dbdf5dda3d21eff0674d426582f (patch)
treea61d2e18006d187d451d76150a8ad5f8aa4ab4f4 /databases/pglogical
parent9bc5e0522add928ba93bb0ec84be7f8d64f66ea4 (diff)
downloadports-fc02e3fd431a0dbdf5dda3d21eff0674d426582f.tar.gz
ports-fc02e3fd431a0dbdf5dda3d21eff0674d426582f.zip
Fix compilation with postgresql11. With previous versions of
postgresql, <arpa/inet.h> was included automatically as part of the postgres module building environment. But it needs to be included explicitly for the most recent postgres. Submitted by: andriy@irbisnet.com
Notes
Notes: svn path=/head/; revision=494778
Diffstat (limited to 'databases/pglogical')
-rw-r--r--databases/pglogical/Makefile4
-rw-r--r--databases/pglogical/files/extra-patch-pglogical__apply__spi.c10
2 files changed, 14 insertions, 0 deletions
diff --git a/databases/pglogical/Makefile b/databases/pglogical/Makefile
index 452a5b110a00..f81b39c62131 100644
--- a/databases/pglogical/Makefile
+++ b/databases/pglogical/Makefile
@@ -36,6 +36,10 @@ PLIST_SUB+= PGSQL94=""
PLIST_SUB+= PGSQL94="@comment "
.endif
+.if ${PGSQL_VER} >= 11
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-pglogical__apply__spi.c
+.endif
+
# FFI
#TEST_DEPENDS= pg_regress:databases/postgresql${PGSQL_VER_NODOT}-pg_regress
#TEST_TARGET= do-test
diff --git a/databases/pglogical/files/extra-patch-pglogical__apply__spi.c b/databases/pglogical/files/extra-patch-pglogical__apply__spi.c
new file mode 100644
index 000000000000..7f9bbc766499
--- /dev/null
+++ b/databases/pglogical/files/extra-patch-pglogical__apply__spi.c
@@ -0,0 +1,10 @@
+--- pglogical_apply_spi.c.orig 2019-03-06 06:44:31 UTC
++++ pglogical_apply_spi.c
+@@ -16,6 +16,7 @@
+ */
+ #include <stdio.h>
+ #include <unistd.h>
++#include <arpa/inet.h>
+
+ #include "postgres.h"
+