aboutsummaryrefslogtreecommitdiff
path: root/databases/pgmetrics
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2018-03-06 11:50:12 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2018-03-06 11:50:12 +0000
commit54a61d98ae7e0c55aca14f0ddd8804edb639662f (patch)
tree55e247ff1004d347923eede3ba677d03e997cadb /databases/pgmetrics
parentdc08b227bc5ff04e9361c30888039234c6f759b2 (diff)
downloadports-54a61d98ae7e0c55aca14f0ddd8804edb639662f.tar.gz
ports-54a61d98ae7e0c55aca14f0ddd8804edb639662f.zip
Add new port datagbases/pgmetrics
This port easily collect and report PostgreSQL metrics for scripting, automation and troubleshooting.
Notes
Notes: svn path=/head/; revision=463711
Diffstat (limited to 'databases/pgmetrics')
-rw-r--r--databases/pgmetrics/Makefile28
-rw-r--r--databases/pgmetrics/distinfo3
-rw-r--r--databases/pgmetrics/files/patch-cmd_pgmetrics_system__freebsd.go24
-rw-r--r--databases/pgmetrics/pkg-descr4
-rw-r--r--databases/pgmetrics/pkg-plist1
5 files changed, 60 insertions, 0 deletions
diff --git a/databases/pgmetrics/Makefile b/databases/pgmetrics/Makefile
new file mode 100644
index 000000000000..433fed715024
--- /dev/null
+++ b/databases/pgmetrics/Makefile
@@ -0,0 +1,28 @@
+# Created by: Palle Girgensohn <girgen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pgmetrics
+PORTVERSION= 1.1.0
+DISTVERSIONPREFIX=v
+CATEGORIES= databases
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= Collect and display info & stats from a running PostgreSQL server
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_ACCOUNT= rapidloop
+
+USES= go
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+BUILD_AS_NON_ROOT=yes
+
+do-build:
+ @cd ${GO_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} build ./cmd/pgmetrics
+
+do-install:
+ @cd ${GO_WRKSRC}; ${INSTALL} ${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/databases/pgmetrics/distinfo b/databases/pgmetrics/distinfo
new file mode 100644
index 000000000000..6c93cedaa92d
--- /dev/null
+++ b/databases/pgmetrics/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520334659
+SHA256 (rapidloop-pgmetrics-v1.1.0_GH0.tar.gz) = 8add03f94ff84e597bc16e750279744bc8913de5acc063683ef0e282ae870b93
+SIZE (rapidloop-pgmetrics-v1.1.0_GH0.tar.gz) = 856131
diff --git a/databases/pgmetrics/files/patch-cmd_pgmetrics_system__freebsd.go b/databases/pgmetrics/files/patch-cmd_pgmetrics_system__freebsd.go
new file mode 100644
index 000000000000..dfcb8a416cd4
--- /dev/null
+++ b/databases/pgmetrics/files/patch-cmd_pgmetrics_system__freebsd.go
@@ -0,0 +1,24 @@
+--- /dev/null 2018-03-06 12:20:46.000000000 +0100
++++ cmd/pgmetrics/system_freebsd.go 2018-03-06 12:18:41.362207000 +0100
+@@ -0,0 +1,21 @@
++/*
++ * Copyright 2018 RapidLoop, Inc.
++ *
++ * Licensed under the Apache License, Version 2.0 (the "License");
++ * you may not use this file except in compliance with the License.
++ * You may obtain a copy of the License at
++ *
++ * http://www.apache.org/licenses/LICENSE-2.0
++ *
++ * Unless required by applicable law or agreed to in writing, software
++ * distributed under the License is distributed on an "AS IS" BASIS,
++ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++ * See the License for the specific language governing permissions and
++ * limitations under the License.
++ */
++
++package main
++
++func (c *collector) collectSystem(o options) {
++ // Not implemented for FreeBSD yet.
++}
diff --git a/databases/pgmetrics/pkg-descr b/databases/pgmetrics/pkg-descr
new file mode 100644
index 000000000000..090706e24309
--- /dev/null
+++ b/databases/pgmetrics/pkg-descr
@@ -0,0 +1,4 @@
+pgmetrics collects and displays various information and statistics from a
+running PostgreSQL server to aid in troubleshooting, monitoring and automation.
+
+WWW: https://pgmetrics.io/
diff --git a/databases/pgmetrics/pkg-plist b/databases/pgmetrics/pkg-plist
new file mode 100644
index 000000000000..1328f0e285ef
--- /dev/null
+++ b/databases/pgmetrics/pkg-plist
@@ -0,0 +1 @@
+bin/pgmetrics