aboutsummaryrefslogtreecommitdiff
path: root/databases/pgmodeler
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-05-15 18:20:49 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-05-15 18:20:49 +0000
commit11ff1398423f79d1767e737eb9ab5dae4fc625b3 (patch)
tree376ac756f3bd4634534e49c12d3f2b71c0a3f1b4 /databases/pgmodeler
parent61a7d440a8f0e19d5b71a30758e15dfd13ef7601 (diff)
downloadports-11ff1398423f79d1767e737eb9ab5dae4fc625b3.tar.gz
ports-11ff1398423f79d1767e737eb9ab5dae4fc625b3.zip
Add an upstream patch to fix the build with Qt 5.10.
src/ui_sqlexecutionwidget.h:186:34: error: no viable conversion from 'QLatin1String' to 'const QKeySequence' snippets_tb->setShortcut(QLatin1String("Alt+X")); ^~~~~~~~~~~~~~~~~~~~~~ PR: 228213
Notes
Notes: svn path=/head/; revision=470042
Diffstat (limited to 'databases/pgmodeler')
-rw-r--r--databases/pgmodeler/Makefile2
-rw-r--r--databases/pgmodeler/files/patch-git_309be58b39
2 files changed, 40 insertions, 1 deletions
diff --git a/databases/pgmodeler/Makefile b/databases/pgmodeler/Makefile
index 42c332443d01..cca1a4786faa 100644
--- a/databases/pgmodeler/Makefile
+++ b/databases/pgmodeler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pgmodeler
PORTVERSION= 0.9.0
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= databases
diff --git a/databases/pgmodeler/files/patch-git_309be58b b/databases/pgmodeler/files/patch-git_309be58b
new file mode 100644
index 000000000000..586d6f5258bd
--- /dev/null
+++ b/databases/pgmodeler/files/patch-git_309be58b
@@ -0,0 +1,39 @@
+From 309be58bbb2b47ca530eecdaf38f2965e35da4f1 Mon Sep 17 00:00:00 2001
+From: "Raphael A. Silva" <rkhaotix@gmail.com>
+Date: Mon, 26 Feb 2018 17:27:09 -0300
+Subject: [PATCH] Fixed a problem with sqlexecutionwidget.ui that is not
+ building properly in Qt 5.10
+
+---
+ libpgmodeler_ui/ui/sqlexecutionwidget.ui | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- libpgmodeler_ui/ui/sqlexecutionwidget.ui
++++ libpgmodeler_ui/ui/sqlexecutionwidget.ui
+@@ -199,7 +199,7 @@
+ </size>
+ </property>
+ <property name="shortcut">
+- <string>Ctrl+S</string>
++ <string notr="true"/>
+ </property>
+ <property name="checkable">
+ <bool>true</bool>
+@@ -316,7 +316,7 @@
+ </size>
+ </property>
+ <property name="shortcut">
+- <string notr="true">Alt+X</string>
++ <string>Alt+T</string>
+ </property>
+ <property name="checkable">
+ <bool>false</bool>
+@@ -360,7 +360,7 @@
+ </size>
+ </property>
+ <property name="shortcut">
+- <string notr="true">Alt+X</string>
++ <string>Alt+X</string>
+ </property>
+ <property name="checkable">
+ <bool>false</bool>