aboutsummaryrefslogtreecommitdiff
path: root/databases/pgrouting
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-05-29 19:29:18 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-05-29 19:29:18 +0000
commit55e4a46b72c21c39a558a31bc9f4fad6f8484a89 (patch)
tree7775a14568f42674c7418410063014b27a3ce5c0 /databases/pgrouting
parent9b415edf29adae049246a640cb24adcdbb733ca1 (diff)
downloadports-55e4a46b72c21c39a558a31bc9f4fad6f8484a89.tar.gz
ports-55e4a46b72c21c39a558a31bc9f4fad6f8484a89.zip
Fix for postgresql > 9.0.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=355733
Diffstat (limited to 'databases/pgrouting')
-rw-r--r--databases/pgrouting/Makefile28
-rw-r--r--databases/pgrouting/pkg-plist17
2 files changed, 21 insertions, 24 deletions
diff --git a/databases/pgrouting/Makefile b/databases/pgrouting/Makefile
index cdb182b4dfca..efc32811bbf4 100644
--- a/databases/pgrouting/Makefile
+++ b/databases/pgrouting/Makefile
@@ -24,27 +24,21 @@ USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PGSQL_VER= ${DEFAULT_PGSQL_VER}
-
-.if ${PGSQL_VER} >= 91
-EXT_FILES= pgrouting--2.0.0.sql \
- pgrouting.control \
- pgrouting_dd_legacy.sql \
- pgrouting--2.0.0.sql.in \
- pgrouting.sql \
- pgrouting_legacy.sql
-PLIST_DIRSTRY+= share/postgresql/extension
-.for f in ${EXT_FILES}
-PLIST_FILES+= share/postgresql/extension/${f}
-.endfor
-.endif
+.include <bsd.port.pre.mk>
+
+.if ${PGSQL_VER} >= 9.1
+PLIST_SUB+= OLDPG="@comment " NEWPG=""
+
post-install:
-.if ${PGSQL_VER} >= 91
@${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/extension
-.for f in ${EXT_FILES}
+.for f in pgrouting--2.0.0.sql pgrouting.control pgrouting_dd_legacy.sql \
+ pgrouting--2.0.0.sql.in pgrouting.sql pgrouting_legacy.sql
${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/share/postgresql/extension/
.endfor
+
+.else
+PLIST_SUB+= OLDPG="" NEWPG="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/pgrouting/pkg-plist b/databases/pgrouting/pkg-plist
index 388f4c3f6e24..d8eb66cfeeea 100644
--- a/databases/pgrouting/pkg-plist
+++ b/databases/pgrouting/pkg-plist
@@ -7,11 +7,14 @@ share/postgresql/contrib/pgrouting-2.0/pgrouting.control
share/postgresql/contrib/pgrouting-2.0/pgrouting.sql
share/postgresql/contrib/pgrouting-2.0/pgrouting_dd_legacy.sql
share/postgresql/contrib/pgrouting-2.0/pgrouting_legacy.sql
-share/postgresql/pgrouting--2.0.0.sql
-share/postgresql/pgrouting.control
-share/postgresql/pgrouting_dd_legacy.sql
-share/postgresql/pgrouting_legacy.sql
+%%OLDPG%%share/postgresql/pgrouting--2.0.0.sql
+%%OLDPG%%share/postgresql/pgrouting.control
+%%OLDPG%%share/postgresql/pgrouting_dd_legacy.sql
+%%OLDPG%%share/postgresql/pgrouting_legacy.sql
+%%NEWPG%%share/postgresql/extension/pgrouting--2.0.0.sql
+%%NEWPG%%share/postgresql/extension/pgrouting.control
+%%NEWPG%%share/postgresql/extension/pgrouting_dd_legacy.sql
+%%NEWPG%%share/postgresql/extension/pgrouting--2.0.0.sql.in
+%%NEWPG%%share/postgresql/extension/pgrouting.sql
+%%NEWPG%%share/postgresql/extension/pgrouting_legacy.sql
@dirrmtry share/postgresql/contrib/pgrouting-2.0
-@dirrmtry share/postgresql/contrib
-@dirrmtry share/postgresql
-@dirrmtry lib/postgresql