aboutsummaryrefslogtreecommitdiff
path: root/databases/phppgadmin/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-05-04 22:48:03 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-05-04 22:48:03 +0000
commit5ac18767d1594a7c77ba505b9672eb4e3b5284bc (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /databases/phppgadmin/Makefile
parentb3db8883de118166da92dad3b8b07b17378c911c (diff)
downloadports-5ac18767d1594a7c77ba505b9672eb4e3b5284bc.tar.gz
ports-5ac18767d1594a7c77ba505b9672eb4e3b5284bc.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=317389
Diffstat (limited to 'databases/phppgadmin/Makefile')
-rw-r--r--databases/phppgadmin/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index 91d6b703058e..9cbea2022f1b 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -40,9 +40,9 @@ do-install:
${CP} -Rp ${WRKSRC}/ ${PREFIX}/${PGADMDIR}/
.if exists(${PREFIX}/${PGADMOLDDIR}/conf/config.inc.php)
${CP} -np ${PREFIX}/${PGADMOLDDIR}/conf/config.inc.php \
- ${PREFIX}/${PGADMDIR}/conf/config.inc.php
+ ${PREFIX}/${PGADMDIR}/conf/config.inc.php || ${TRUE}
.endif
${CP} -np ${PREFIX}/${PGADMDIR}/conf/config.inc.php-dist \
- ${PREFIX}/${PGADMDIR}/conf/config.inc.php
+ ${PREFIX}/${PGADMDIR}/conf/config.inc.php || ${TRUE}
.include <bsd.port.post.mk>