aboutsummaryrefslogtreecommitdiff
path: root/databases/phppgadmin/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-03-22 14:38:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-03-22 14:38:02 +0000
commitdeb1a69ee575020b989b277ed5365bdbbf9b7f09 (patch)
treefa3611f152282a809d54f665ed1a34e39012ff76 /databases/phppgadmin/Makefile
parentb99c6b9562c75f5888eb75922bfbfdec5fca63d6 (diff)
downloadports-deb1a69ee575020b989b277ed5365bdbbf9b7f09.tar.gz
ports-deb1a69ee575020b989b277ed5365bdbbf9b7f09.zip
Notes
Diffstat (limited to 'databases/phppgadmin/Makefile')
-rw-r--r--databases/phppgadmin/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index 4c9a263cfbd1..44c485b9d020 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= phppgadmin
-PORTVERSION= 3.2.1
+PORTVERSION= 3.3.1
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +15,7 @@ DISTNAME= phpPgAdmin-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Web Based Postgres Administration
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_PHP= yes
WRKSRC= ${WRKDIR}/phpPgAdmin
@@ -24,8 +25,17 @@ PHP_PORT?= www/mod_php4-twig
PGADMDIR?= www/data/phpPgAdmin
PLIST_SUB+= PGADMDIR=${PGADMDIR}
+do-configure:
+ ${REINPLACE_CMD} -e "s|/usr/bin/pg|${LOCALBASE}/bin/pg|" \
+ ${WRKSRC}/conf/config.inc.php-dist
+ rm -f ${WRKSRC}/conf/config.inc.php \
+ ${WRKSRC}/conf/config.inc.php-dist.bak
+
do-install:
${MKDIR} ${PREFIX}/${PGADMDIR}
${CP} -R ${WRKSRC}/* ${PREFIX}/${PGADMDIR}
+ @[ -f ${PREFIX}/${PGADMDIR}/conf/config.inc.php ] || \
+ cp ${PREFIX}/${PGADMDIR}/conf/config.inc.php-dist \
+ ${PREFIX}/${PGADMDIR}/conf/config.inc.php
.include <bsd.port.mk>