aboutsummaryrefslogtreecommitdiff
path: root/databases/phppgadmin
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-02-07 12:53:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-02-07 12:53:45 +0000
commitc800429854871629db21cf03901040be83309785 (patch)
treeb4b130914fb290eb6144fdb9358a9cde7b60c24f /databases/phppgadmin
parent435b06d4d6611336696ad34034f9cdfd45414c58 (diff)
downloadports-c800429854871629db21cf03901040be83309785.tar.gz
ports-c800429854871629db21cf03901040be83309785.zip
- fix postgresql-8.1
PR: 108832 Submitted by: Henrik Brix Andersen Obtained from: CVS
Notes
Notes: svn path=/head/; revision=184488
Diffstat (limited to 'databases/phppgadmin')
-rw-r--r--databases/phppgadmin/Makefile2
-rw-r--r--databases/phppgadmin/files/patch-Postgres81.php11
2 files changed, 13 insertions, 0 deletions
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index 8cf7a29e4888..2ab28e399258 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= phppgadmin
PORTVERSION= 4.1
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -39,6 +40,7 @@ do-configure:
do-install:
${MKDIR} ${PREFIX}/${PGADMDIR}
+ ${RM} -f ${WRKSRC}/classes/database/Postgres81.php.orig
${CP} -Rp ${WRKSRC}/ ${PREFIX}/${PGADMDIR}/
.if exists(${DESTDIR}${PREFIX}/${PGADMOLDDIR}/conf/config.inc.php)
${CP} -np ${DESTDIR}${PREFIX}/${PGADMOLDDIR}/conf/config.inc.php \
diff --git a/databases/phppgadmin/files/patch-Postgres81.php b/databases/phppgadmin/files/patch-Postgres81.php
new file mode 100644
index 000000000000..ef88221bdab3
--- /dev/null
+++ b/databases/phppgadmin/files/patch-Postgres81.php
@@ -0,0 +1,11 @@
+--- classes/database/Postgres81.php.orig Tue Feb 6 14:00:38 2007
++++ classes/database/Postgres81.php Tue Feb 6 14:01:02 2007
+@@ -83,7 +83,7 @@ class Postgres81 extends Postgres80 {
+ if (isset($conf['owned_only']) && $conf['owned_only'] && !$this->isSuperUser($server_info['username'])) {
+ $username = $server_info['username'];
+ $this->clean($username);
+- $clause = " AND pu.usename='{$username}'";
++ $clause = " AND pr.rolname='{$username}'";
+ }
+ else $clause = '';
+