aboutsummaryrefslogtreecommitdiff
path: root/databases/plpgsql_check
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-30 20:02:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-30 20:02:43 +0000
commit75f71c49d1f1e16db8702118c4574e991e5985fc (patch)
tree85f1ace874b9a8753358b320423de8966e75531c /databases/plpgsql_check
parentfb4dae6760d3d5cea20cb8c43753152573ae78d1 (diff)
downloadports-75f71c49d1f1e16db8702118c4574e991e5985fc.tar.gz
ports-75f71c49d1f1e16db8702118c4574e991e5985fc.zip
databases/plpgsql_check: fix build on GCC architectures
Use C11 compiler: src/expr_walk.c:37: error: redefinition of typedef 'check_function_callback' /usr/local/include/postgresql/server/nodes/nodeFuncs.h:30: error: previous declaration of 'check_function_callback' was here
Notes
Notes: svn path=/head/; revision=547078
Diffstat (limited to 'databases/plpgsql_check')
-rw-r--r--databases/plpgsql_check/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/databases/plpgsql_check/Makefile b/databases/plpgsql_check/Makefile
index 2ff4828f9bd2..db590a71f9b6 100644
--- a/databases/plpgsql_check/Makefile
+++ b/databases/plpgsql_check/Makefile
@@ -15,7 +15,7 @@ LICENSE_NAME= postcardware
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror pkg-mirror dist-sell pkg-sell auto-accept
-USES= gmake pgsql
+USES= compiler:c11 gmake pgsql
LLD_UNSAFE= yes
WANT_PGSQL= server
@@ -25,6 +25,8 @@ PLIST_SUB= PORTVERSION=${PORTVERSION:R}
USE_GITHUB= yes
GH_ACCOUNT= okbob
+MAKE_ARGS= CC="${CC}"
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/plpgsql_check.so