aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-cstore_fdw
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-13 10:28:30 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-13 10:28:30 +0000
commit6205b2464def3845e323ffe3d51ecd2be114a55a (patch)
tree5d87d4a1519c9090da6363917c281d798feb4e20 /databases/postgresql-cstore_fdw
parent910003f072dbf1a1c2794806aba9b8adfe6bd10d (diff)
downloadports-6205b2464def3845e323ffe3d51ecd2be114a55a.tar.gz
ports-6205b2464def3845e323ffe3d51ecd2be114a55a.zip
New port: databases/postgresql-cstore_fdw
Cstore_fdw is a extension of PostgreSQL. This extension uses the Optimized Row Columnar (ORC) format for its data layout. ORC improves upon the RCFile format developed at Facebook, and brings the following benefits: - Compression: Reduces in-memory and on-disk data size by 2-4x. Can be extended to support different codecs. - Column projections: Only reads column data relevant to the query. Improves performance for I/O bound queries. - Skip indexes: Stores min/max statistics for row groups, and uses them to skip over unrelated rows. Further, cstore_fdw used the Postgres foreign data wrapper APIs and type representations with this extension. This brings: - Support for 40+ Postgres data types. The user can also create new types and use them. - Statistics collection. PostgreSQL's query optimizer uses these stats to evaluate different query plans and pick the best one. - Simple setup. Create foreign table and copy data. Run SQL. WWW: https://github.com/citusdata/cstore_fdw PR: 219635 Submitted by: Jov <amutu@amutu.com>
Notes
Notes: svn path=/head/; revision=443496
Diffstat (limited to 'databases/postgresql-cstore_fdw')
-rw-r--r--databases/postgresql-cstore_fdw/Makefile23
-rw-r--r--databases/postgresql-cstore_fdw/distinfo3
-rw-r--r--databases/postgresql-cstore_fdw/pkg-descr18
-rw-r--r--databases/postgresql-cstore_fdw/pkg-plist8
4 files changed, 52 insertions, 0 deletions
diff --git a/databases/postgresql-cstore_fdw/Makefile b/databases/postgresql-cstore_fdw/Makefile
new file mode 100644
index 000000000000..b20ef2de2208
--- /dev/null
+++ b/databases/postgresql-cstore_fdw/Makefile
@@ -0,0 +1,23 @@
+# Created by: Jov <amutu@amutu.com>
+# $FreeBSD$
+
+PORTNAME= cstore_fdw
+PORTVERSION= 1.5.1
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= amutu@amutu.com
+COMMENT= Columnar store for analytics with PostgreSQL
+
+LICENSE= PostgreSQL
+
+LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c
+
+USES= gmake pgsql:9.3+
+USE_GITHUB= yes
+GH_ACCOUNT= citusdata
+
+WANT_PGSQL= server
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-cstore_fdw/distinfo b/databases/postgresql-cstore_fdw/distinfo
new file mode 100644
index 000000000000..b8659668a9fb
--- /dev/null
+++ b/databases/postgresql-cstore_fdw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496052817
+SHA256 (citusdata-cstore_fdw-v1.5.1_GH0.tar.gz) = dd1b6884ab9b21a6a90461df53d1ab7336fec4c4ff3073ee0a916b0bcbb5a44c
+SIZE (citusdata-cstore_fdw-v1.5.1_GH0.tar.gz) = 87684
diff --git a/databases/postgresql-cstore_fdw/pkg-descr b/databases/postgresql-cstore_fdw/pkg-descr
new file mode 100644
index 000000000000..1e79b400b0d2
--- /dev/null
+++ b/databases/postgresql-cstore_fdw/pkg-descr
@@ -0,0 +1,18 @@
+Cstore_fdw is a extension of PostgreSQL. This extension uses the Optimized Row
+Columnar (ORC) format for its data layout. ORC improves upon the RCFile format
+developed at Facebook, and brings the following benefits:
+ - Compression: Reduces in-memory and on-disk data size by 2-4x. Can be
+ extended to support different codecs.
+ - Column projections: Only reads column data relevant to the query.
+ Improves performance for I/O bound queries.
+ - Skip indexes: Stores min/max statistics for row groups, and uses them
+ to skip over unrelated rows.
+Further, cstore_fdw used the Postgres foreign data wrapper APIs and type
+representations with this extension. This brings:
+ - Support for 40+ Postgres data types. The user can also create new types
+ and use them.
+ - Statistics collection. PostgreSQL's query optimizer uses these stats to
+ evaluate different query plans and pick the best one.
+ - Simple setup. Create foreign table and copy data. Run SQL.
+
+WWW: https://github.com/citusdata/cstore_fdw
diff --git a/databases/postgresql-cstore_fdw/pkg-plist b/databases/postgresql-cstore_fdw/pkg-plist
new file mode 100644
index 000000000000..8bb7180a7152
--- /dev/null
+++ b/databases/postgresql-cstore_fdw/pkg-plist
@@ -0,0 +1,8 @@
+lib/postgresql/cstore_fdw.so
+share/postgresql/extension/cstore_fdw--1.0--1.1.sql
+share/postgresql/extension/cstore_fdw--1.1--1.2.sql
+share/postgresql/extension/cstore_fdw--1.2--1.3.sql
+share/postgresql/extension/cstore_fdw--1.3--1.4.sql
+share/postgresql/extension/cstore_fdw--1.4--1.5.sql
+share/postgresql/extension/cstore_fdw--1.5.sql
+share/postgresql/extension/cstore_fdw.control