aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql12-server
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-03-06 10:12:18 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-03-06 10:12:18 +0000
commit1f6470a337404bd81078bde84c3955071d2505b1 (patch)
tree42fcad9801f5535ee09e490404b51b7e499b92ff /databases/postgresql12-server
parentf5433d93933056b8330cf927ea6a89b6e0999566 (diff)
downloadports-1f6470a337404bd81078bde84c3955071d2505b1.tar.gz
ports-1f6470a337404bd81078bde84c3955071d2505b1.zip
databases/postgresql12-server: fix build on GCC architectures
Use LLVM only if Clang is used. PR: 244225 Approved by: pgsql (maintainer timeout) MFH: 2020Q1 (fix build blanket)
Notes
Notes: svn path=/head/; revision=527871
Diffstat (limited to 'databases/postgresql12-server')
-rw-r--r--databases/postgresql12-server/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/databases/postgresql12-server/Makefile b/databases/postgresql12-server/Makefile
index 5c38d79a6894..1a8f8f47f7cd 100644
--- a/databases/postgresql12-server/Makefile
+++ b/databases/postgresql12-server/Makefile
@@ -94,7 +94,8 @@ XML_DESC= Build with XML data type
.if ${DISTVERSION:C/([0-9]*).*/\1/} >= 11
OPTIONS_DEFINE+= LLVM
LLVM_DESC= Build with support for JIT-compiling expressions
-OPTIONS_DEFAULT+= LLVM
+OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${CHOSEN_COMPILER_TYPE}}
+OPTIONS_DEFAULT_clang= LLVM
.endif
.if ${DISTVERSION:C/([0-9]*).*/\1/} < 10
@@ -173,6 +174,8 @@ SUB_LIST+= PG_GROUP=${PG_GROUP} \
.if ${ARCH} == "i386"
USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler
.endif
.if ${DISTVERSION:C/([0-9]*).*/\1/} >= 11