aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql13-plpython
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2020-09-24 13:33:10 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2020-09-24 13:33:10 +0000
commitaa1ed0e82cb937b6b71eae980dcc2554d675facb (patch)
treeecc90f2639eec6ac53e43e653a23696b32dbaa7e /databases/postgresql13-plpython
parent0a684a50f544f98bce8b5997fb29adee2cc845c1 (diff)
downloadports-aa1ed0e82cb937b6b71eae980dcc2554d675facb.tar.gz
ports-aa1ed0e82cb937b6b71eae980dcc2554d675facb.zip
Welcome PostgreSQL 13
Notes
Notes: svn path=/head/; revision=549921
Diffstat (limited to 'databases/postgresql13-plpython')
-rw-r--r--databases/postgresql13-plpython/Makefile27
-rw-r--r--databases/postgresql13-plpython/pkg-descr6
2 files changed, 33 insertions, 0 deletions
diff --git a/databases/postgresql13-plpython/Makefile b/databases/postgresql13-plpython/Makefile
new file mode 100644
index 000000000000..4d724d564cc0
--- /dev/null
+++ b/databases/postgresql13-plpython/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= postgresql
+CATEGORIES= databases python
+# Keep the ?=, it is used as master by the other plpython ports.
+PORTREVISION?= 0
+PKGNAMESUFFIX?= ${WANT_PGSQL_VER:S/.//}${COMPONENT}
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= Module for using Python to write SQL functions
+
+USES+= pgsql:${WANT_PGSQL_VER} ${WANT_PYTHON_USE}
+WANT_PGSQL= server
+
+MASTERDIR= ${.CURDIR}/../postgresql${WANT_PGSQL_VER:S/.//}-server
+
+WANT_PGSQL_VER?= 13
+WANT_PYTHON_USE?= python
+
+CONFIGURE_ARGS= --with-python
+COMPONENT= -plpython
+
+BUILD_DIRS= src/backend ${INSTALL_DIRS}
+INSTALL_DIRS?= src/pl/plpython contrib/hstore_plpython contrib/jsonb_plpython contrib/ltree_plpython
+SLAVE_ONLY= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql13-plpython/pkg-descr b/databases/postgresql13-plpython/pkg-descr
new file mode 100644
index 000000000000..416cce467d37
--- /dev/null
+++ b/databases/postgresql13-plpython/pkg-descr
@@ -0,0 +1,6 @@
+PL/Python allows one to write PostgeSQL stored functions and
+procedures in Python (http://www.python.org/).
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: https://www.postgresql.org/