aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql13-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2021-05-15 09:11:12 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2021-05-15 09:12:17 +0000
commitab83f2b4bb78a718efa5c43247ba1e1d207f99b6 (patch)
tree9be699935c09ece31e48a3cded0de3a229c48611 /databases/postgresql13-server
parentccb205d9575685e4002785bec744bea133b27eed (diff)
downloadports-ab83f2b4bb78a718efa5c43247ba1e1d207f99b6.tar.gz
ports-ab83f2b4bb78a718efa5c43247ba1e1d207f99b6.zip
databases/postgresql??-*: Upgrade to latest version
PostgreSQL 13.3, 12.7, 11.12, 10.17, and 9.6.22 Released! The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 13.3, 12.7, 11.12, 10.17, and 9.6.22. This release closes three security vulnerabilities and fixes over 45 bugs reported over the last three months. Security fixes in this release: CVE-2021-32027: Buffer overrun from integer overflow in array subscripting calculations CVE-2021-32028: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE CVE-2021-32029: Memory disclosure in partitioned-table UPDATE ... RETURNING Also plenty of bug fixes. See the release note for details. Changes to the port: Make sure we use the matching version of llvm. This fixes a problem with the llvm version string not being monotonically increasing with the version number. [1] Better pkg message about checksums for postgresql 12+. [2] [4] Adjust login class parameter to adhere to the documentation in rc.subr(8) [3]: The rc.conf parameter for the login class of the postgresql daemon has changed name from postgresql_class to postgresql_login_class, since rc.subr(8) states that the parameter should be named ${name}_login_class. Allow parallel builds. [5] Correct the directory name for the user postgres in pkg message. [6] PR: 250824 [1], 253558 [2], 236060 [3], 233106 [4], 230656 [5] PR: 226674 [6] Submitted by: Michael Zhilin [2], Michael Zhilin [3], Dmitry Chestnykh [4] Submitted by: Steve Wills [5], knezour [6] Security: 76e0bb86-b4cb-11eb-b9c9-6cc21735f730 Security: 62da9702-b4cc-11eb-b9c9-6cc21735f730 Release notes: https://www.postgresql.org/docs/release/
Diffstat (limited to 'databases/postgresql13-server')
-rw-r--r--databases/postgresql13-server/Makefile31
-rw-r--r--databases/postgresql13-server/distinfo6
-rw-r--r--databases/postgresql13-server/files/pkg-message-server.in14
-rw-r--r--databases/postgresql13-server/files/postgresql.in8
-rw-r--r--databases/postgresql13-server/pkg-plist-client1
-rw-r--r--databases/postgresql13-server/pkg-plist-server8
6 files changed, 45 insertions, 23 deletions
diff --git a/databases/postgresql13-server/Makefile b/databases/postgresql13-server/Makefile
index 4305a5ed4d55..a480ca004546 100644
--- a/databases/postgresql13-server/Makefile
+++ b/databases/postgresql13-server/Makefile
@@ -1,10 +1,10 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
PORTNAME?= postgresql
-DISTVERSION?= 13.2
+DISTVERSION?= 13.3
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 1
+PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= PGSQL/source/v${DISTVERSION}
PKGNAMESUFFIX?= ${PORTVERSION:R}${COMPONENT}
@@ -240,26 +240,39 @@ RUN_DEPENDS+= llvm-config${PG_LLVM_VERSION}:devel/llvm${PG_LLVM_VERSION}
CONFIGURE_ENV+= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${PG_LLVM_VERSION}
.endif
+# Convert LLVM_DEFAULT to COMPILER_VERSION format to make it
+# suitable for version comparison.
+.if ${LLVM_DEFAULT} >= 70 && ${LLVM_DEFAULT} <= 90
+LLVM_DEFAULT_VERSION= ${LLVM_DEFAULT}
+.else
+LLVM_DEFAULT_VERSION= ${LLVM_DEFAULT}0
+.endif
+
+# Convert COMPILER_VERSION to LLVM_DEFAULT format to make it
+# suitable for LLVM port name.
+# All supported FreeBSD versions have Clang 10.0.1 or later.
+LLVM_PORT_SUFFIX= ${COMPILER_VERSION:C/.$//}
+
# sync LLVM to the preferred compiler if possible
# or else use a lower version compiler that is compatible
-.if ${COMPILER_VERSION} > ${LLVM_DEFAULT}
+.if ${COMPILER_VERSION} > ${LLVM_DEFAULT_VERSION}
# Highest LLVM version in ports:
-. if ${COMPILER_VERSION} <= 11
-PG_LLVM_VERSION=${COMPILER_VERSION}
-PG_COMPILER_VERSION=${COMPILER_VERSION}
+. if ${LLVM_PORT_SUFFIX} <= 11
+PG_LLVM_VERSION=${LLVM_PORT_SUFFIX}
+PG_COMPILER_VERSION=${LLVM_PORT_SUFFIX}
. else
PG_LLVM_VERSION=11
PG_COMPILER_VERSION=11
. endif
.else
-PG_COMPILER_VERSION=${COMPILER_VERSION}
PG_LLVM_VERSION=${LLVM_DEFAULT}
+PG_COMPILER_VERSION=${LLVM_PORT_SUFFIX}
.endif
.if ${DISTVERSION:C/([0-9]*).*/\1/} >= 11
. if defined(SERVER_ONLY) && ${PORT_OPTIONS:MLLVM}
INSTALL_DIRS+= src/backend/jit/llvm
-. if ${COMPILER_VERSION} != ${PG_COMPILER_VERSION}
+. if ${LLVM_PORT_SUFFIX} != ${PG_COMPILER_VERSION}
LLVM_CONFIGURE_ARGS?= CC=${LOCALBASE}/bin/clang${PG_COMPILER_VERSION}
. endif
. endif
@@ -275,7 +288,7 @@ pre-build:
do-build:
@ cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks
@ for dir in ${BUILD_DIRS}; do \
- cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD}; \
+ cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${_MAKE_JOBS}; \
done
. if exists(${FILESDIR}/pkg-message${COMPONENT}.in)
diff --git a/databases/postgresql13-server/distinfo b/databases/postgresql13-server/distinfo
index 4daa9fa2e5a1..9ac2c3dbf1f6 100644
--- a/databases/postgresql13-server/distinfo
+++ b/databases/postgresql13-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612956695
-SHA256 (postgresql/postgresql-13.2.tar.bz2) = 5fd7fcd08db86f5b2aed28fcfaf9ae0aca8e9428561ac547764c2a2b0f41adfc
-SIZE (postgresql/postgresql-13.2.tar.bz2) = 21057276
+TIMESTAMP = 1620992128
+SHA256 (postgresql/postgresql-13.3.tar.bz2) = 3cd9454fa8c7a6255b6743b767700925ead1b9ab0d7a0f9dcb1151010f8eb4a1
+SIZE (postgresql/postgresql-13.3.tar.bz2) = 21119109
diff --git a/databases/postgresql13-server/files/pkg-message-server.in b/databases/postgresql13-server/files/pkg-message-server.in
index 84a13f7cb47c..9bfbcc7b4a83 100644
--- a/databases/postgresql13-server/files/pkg-message-server.in
+++ b/databases/postgresql13-server/files/pkg-message-server.in
@@ -14,7 +14,7 @@ is a periodic script, %%PREFIX%%/etc/periodic/daily/502.pgsql, that
you may find useful. You can use it to backup and perform vacuum on all
databases nightly. Per default, it performs `vacuum analyze'. See the
script for instructions. For autovacuum settings, please review
-~pgsql/data/postgresql.conf.
+~postgres/data/postgresql.conf.
If you plan to access your PostgreSQL server using ODBC, please
consider running the SQL script %%PREFIX%%/share/postgresql/odbc.sql
@@ -48,17 +48,17 @@ You can then start PostgreSQL by running:
%%PREFIX%%/etc/rc.d/postgresql start
-For postmaster settings, see ~pgsql/data/postgresql.conf
+For postmaster settings, see ~postgres/data/postgresql.conf
NB. FreeBSD's PostgreSQL port logs to syslog by default
- See ~pgsql/data/postgresql.conf for more info
+ See ~postgres/data/postgresql.conf for more info
NB. If you're not using a checksumming filesystem like ZFS, you might
- wish to enable data checksumming. It can only be enabled during
+ wish to enable data checksumming. It can be enabled during
the initdb phase, by adding the "--data-checksums" flag to
- the postgres_initdb_flags rcvar. Check the initdb(1) manpage
- for more info and make sure you understand the performance
- implications.
+ the postgresql_initdb_flags rcvar. Otherwise you can enable it later by
+ pg_checksums. Check the initdb(1) manpage for more info
+ and make sure you understand the performance implications.
======================================================================
diff --git a/databases/postgresql13-server/files/postgresql.in b/databases/postgresql13-server/files/postgresql.in
index a123816264b8..d04d3c3fd1a8 100644
--- a/databases/postgresql13-server/files/postgresql.in
+++ b/databases/postgresql13-server/files/postgresql.in
@@ -1,7 +1,7 @@
#!/bin/sh
# PROVIDE: postgresql
-# REQUIRE: sshd
+# REQUIRE: SERVERS
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable PostgreSQL:
@@ -11,7 +11,7 @@
# postgresql_data="/var/db/%%PG_USER%%/data13"
# postgresql_flags="-w -s -m fast"
# postgresql_initdb_flags="--encoding=utf-8 --lc-collate=C"
-# postgresql_class="default"
+# postgresql_login_class="default"
# postgresql_profiles=""
#
# See %%PREFIX%%/share/doc/postgresql/README-server for more info
@@ -33,7 +33,7 @@ postgresql_enable=${postgresql_enable:-"NO"}
postgresql_flags=${postgresql_flags:-"-w -s -m fast"}
postgresql_user=${postgresql_user:-"%%PG_USER%%"}
eval postgresql_data=${postgresql_data:-"~${postgresql_user}/data13"}
-postgresql_class=${postgresql_class:-"default"}
+postgresql_login_class=${postgresql_login_class:-"default"}
postgresql_initdb_flags=${postgresql_initdb_flags:-"--encoding=utf-8 --lc-collate=C"}
name=postgresql
@@ -109,7 +109,7 @@ postgresql_command()
postgresql_initdb()
{
- ${su_cmd} -l -c ${postgresql_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data} -U ${postgresql_user}"
+ ${su_cmd} -l -c ${postgresql_login_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data} -U ${postgresql_user}"
}
run_rc_command "$1"
diff --git a/databases/postgresql13-server/pkg-plist-client b/databases/postgresql13-server/pkg-plist-client
index 0a4ef08da6be..08e9bf92fc5b 100644
--- a/databases/postgresql13-server/pkg-plist-client
+++ b/databases/postgresql13-server/pkg-plist-client
@@ -1192,6 +1192,7 @@ man/man7/WITH.7.gz
%%NLS%%share/locale/pt_BR/LC_MESSAGES/ecpg-13.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/ecpglib6-13.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_config-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pgscripts-13.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ecpg-13.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ecpglib6-13.mo
%%NLS%%share/locale/ru/LC_MESSAGES/libpq5-13.mo
diff --git a/databases/postgresql13-server/pkg-plist-server b/databases/postgresql13-server/pkg-plist-server
index ef2256fa8ec2..6dd25fc3fcdf 100644
--- a/databases/postgresql13-server/pkg-plist-server
+++ b/databases/postgresql13-server/pkg-plist-server
@@ -827,6 +827,14 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/pl/LC_MESSAGES/pg_test_fsync-13.mo
%%NLS%%share/locale/pl/LC_MESSAGES/pg_test_timing-13.mo
%%NLS%%share/locale/pl/LC_MESSAGES/plpgsql-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/initdb-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_archivecleanup-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_checksums-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_controldata-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_ctl-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_resetwal-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_test_fsync-13.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_test_timing-13.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/plpgsql-13.mo
%%NLS%%share/locale/ru/LC_MESSAGES/initdb-13.mo
%%NLS%%share/locale/ru/LC_MESSAGES/pg_archivecleanup-13.mo