aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql92-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2010-10-07 06:58:10 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2010-10-07 06:58:10 +0000
commit060a528952c060d3cacb5faa2337b86a947f9cc1 (patch)
treec42f4aa0bb5da6b4d3d55839fff8d1bbed9e71f3 /databases/postgresql92-server
parentbd169d68cc2b63d4f9e6017ffe8875de63696ede (diff)
downloadports-060a528952c060d3cacb5faa2337b86a947f9cc1.tar.gz
ports-060a528952c060d3cacb5faa2337b86a947f9cc1.zip
Notes
Diffstat (limited to 'databases/postgresql92-server')
-rw-r--r--databases/postgresql92-server/Makefile38
-rw-r--r--databases/postgresql92-server/distinfo6
-rw-r--r--databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample14
-rw-r--r--databases/postgresql92-server/pkg-plist-client7
-rw-r--r--databases/postgresql92-server/pkg-plist-contrib1
-rw-r--r--databases/postgresql92-server/pkg-plist-server5
6 files changed, 47 insertions, 24 deletions
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 80d9c75a968c..37fab5268407 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= postgresql
-DISTVERSION?= 9.0.0
+DISTVERSION?= 9.0.1
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -36,17 +36,21 @@ GNU_CONFIGURE= YES
PGUSER= pgsql
PGGROUP= pgsql
-CONFIGURE_ARGS+=--with-libraries=${LOCALBASE}/lib \
- --with-includes=${LOCALBASE}/include \
+LDFLAGS+= -L${LOCALBASE}/lib
+INCLUDES+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+=--with-libraries=${PREFIX}/lib \
+ --with-includes=${PREFIX}/include \
--enable-thread-safety
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" \
+ INCLUDES="${INCLUDES}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST= ${PKGDIR}/pkg-plist${PKGNAMESUFFIX}
-BUILD_DIRS?= src/port src/timezone src/backend src/backend/utils/mb/conversion_procs \
- src/backend/snowball src/bin/initdb src/bin/pg_ctl \
+BUILD_DIRS?= src/timezone src/backend src/backend/utils/mb/conversion_procs \
+ src/backend/snowball src/backend/replication/libpqwalreceiver \
+ src/bin/initdb src/bin/pg_ctl \
src/bin/pg_controldata src/bin/pg_resetxlog src/pl
INSTALL_DIRS?= ${BUILD_DIRS}
@@ -89,6 +93,7 @@ OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
OPTIONS+= XML "Build with XML data type (server)" on
OPTIONS+= TZDATA "Use internal timezone database (server)" on
OPTIONS+= DEBUG "Builds with debugging symbols" off
+OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
OPTIONS+= ICU "Use ICU 3.x for unicode collation (server)" off
@@ -116,26 +121,30 @@ LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
PATCH_DIST_STRIP=-p1
-. if defined(SERVER_ONLY) && defined(WITH_DTRACE)
+. if defined(WITH_DTRACE)
CONFIGURE_ARGS+=--enable-dtrace
LDFLAGS+=-lelf
. endif
-. if defined(SERVER_ONLY) && defined(WITH_PAM)
+. if defined(WITH_PAM)
CONFIGURE_ARGS+=--with-pam
. endif
-. if defined(SERVER_ONLY) && defined(WITH_LDAP)
+. if defined(WITH_LDAP)
CONFIGURE_ARGS+=--with-ldap
+. if defined (SERVER_ONLY)
USE_OPENLDAP= YES
+. endif
. endif
-. if defined(SERVER_ONLY) && defined(WITH_XML)
+. if defined(WITH_XML)
CONFIGURE_ARGS+=--with-libxml
+. if defined (SERVER_ONLY)
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
+. endif
. endif
-. if defined(SERVER_ONLY) && defined(WITH_TZDATA)
+. if defined(WITH_TZDATA)
PLIST_SUB+= TZDATA=""
. else
CONFIGURE_ARGS+=--with-system-tzdata=/usr/share/zoneinfo
@@ -166,6 +175,10 @@ INSTALL_TARGET= install
INSTALL_TARGET= install-strip
. endif
+.if (${OSVERSION} >= 700000) && !defined(WITHOUT_GSSAPI)
+CONFIGURE_ARGS+=--with-gssapi
+.endif
+
. if defined(WITH_MIT_KRB5)
. if exists(/usr/lib/libkrb5.so) || exists(/usr/bin/krb5-config)
BROKEN= "You must remove heimdal's /usr/bin/krb5-config and /usr/lib/libkrb5.so*, and set NO_KERBEROS=true in /etc/make.conf to build successfully with MIT-KRB"
@@ -313,6 +326,11 @@ pre-su-install:
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
+. if defined(WITH_ICU) || defined(WITH_ICU4)
+ @${REINPLACE_CMD} -E -e \
+ "s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION:S/2/2./}\2${AUTOCONF_VERSION:S/2/2./}|g" \
+ ${WRKSRC}/configure.in
+. endif
do-install:
@for dir in ${INSTALL_DIRS}; do \
diff --git a/databases/postgresql92-server/distinfo b/databases/postgresql92-server/distinfo
index d6eca70c281d..d623f4df5ee6 100644
--- a/databases/postgresql92-server/distinfo
+++ b/databases/postgresql92-server/distinfo
@@ -1,6 +1,6 @@
-MD5 (postgresql/postgresql-9.0.0.tar.bz2) = 14c2122cc322e69ab2ab702ed7714bbe
-SHA256 (postgresql/postgresql-9.0.0.tar.bz2) = 7dcc381603c02595adc96a8fc5c9d067d3b39aaa44987e7a524a7504a10ff676
-SIZE (postgresql/postgresql-9.0.0.tar.bz2) = 13753207
+MD5 (postgresql/postgresql-9.0.1.tar.bz2) = 57ba57e43cfe29e16dacbf5789be98d1
+SHA256 (postgresql/postgresql-9.0.1.tar.bz2) = 5310cd490127845f1473a0f73f7b0d18277d81d51534ddfe17ea3e78286a3196
+SIZE (postgresql/postgresql-9.0.1.tar.bz2) = 13773951
SHA256 (postgresql/pg-900-icu-2010-09-19.diff.gz) = 27cea46241ec814965c278330cd96f67ee03422b7758a210713a63b4b5bb77e9
MD5 (postgresql/pg-900-icu-2010-09-19.diff.gz) = 150268fbcce8c0bbe68c176dcb5464ad
SIZE (postgresql/pg-900-icu-2010-09-19.diff.gz) = 4349
diff --git a/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
index 4c32ae4a26bb..3c1609fdbbc7 100644
--- a/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
+++ b/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -1,14 +1,14 @@
---- ./src/backend/utils/misc/postgresql.conf.sample.orig 2009-08-24 22:08:40.000000000 +0200
-+++ ./src/backend/utils/misc/postgresql.conf.sample 2009-10-04 19:21:09.000000000 +0200
-@@ -230,6 +230,7 @@
+--- src/backend/utils/misc/postgresql.conf.sample.orig 2010-10-01 16:25:44.000000000 +0200
++++ src/backend/utils/misc/postgresql.conf.sample 2010-10-05 07:37:35.626282933 +0200
+@@ -256,6 +256,7 @@
# - Where to Log -
+log_destination = 'syslog'
#log_destination = 'stderr' # Valid values are combinations of
- # stderr, csvlog, syslog and eventlog,
+ # stderr, csvlog, syslog, and eventlog,
# depending on platform. csvlog
-@@ -264,6 +265,7 @@
+@@ -290,6 +291,7 @@
#syslog_facility = 'LOCAL0'
#syslog_ident = 'postgres'
@@ -16,10 +16,10 @@
#silent_mode = off # Run server silently.
# DO NOT USE without syslog or
# logging_collector
-@@ -367,6 +369,9 @@
+@@ -394,6 +396,9 @@
#track_counts = on
#track_functions = none # none, pl, all
- #track_activity_query_size = 1024
+ #track_activity_query_size = 1024 # (change requires restart)
+
+# On FreeBSD, this is a performance hog, so keep it off if you need speed
+update_process_title = off
diff --git a/databases/postgresql92-server/pkg-plist-client b/databases/postgresql92-server/pkg-plist-client
index cb6713877cee..e39b4b807380 100644
--- a/databases/postgresql92-server/pkg-plist-client
+++ b/databases/postgresql92-server/pkg-plist-client
@@ -546,12 +546,13 @@ lib/libecpg.so.6
lib/libecpg_compat.a
lib/libecpg_compat.so
lib/libecpg_compat.so.3
+lib/libpgport.a
+lib/libpgtypes.a
+lib/libpgtypes.so
lib/libpgtypes.so.3
lib/libpq.a
lib/libpq.so
lib/libpq.so.5
-lib/libpgtypes.a
-lib/libpgtypes.so
lib/postgresql/pgxs/config/install-sh
lib/postgresql/pgxs/src/makefiles/pgxs.mk
lib/postgresql/pgxs/src/Makefile.global
@@ -641,3 +642,5 @@ share/postgresql/psqlrc.sample
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_config-9.0.mo
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_dump-9.0.mo
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pgscripts-9.0.mo
+@dirrm share/doc/postgresql/html
+@dirrm share/doc/postgresql
diff --git a/databases/postgresql92-server/pkg-plist-contrib b/databases/postgresql92-server/pkg-plist-contrib
index b3a1c61e6d8e..6503200ccb10 100644
--- a/databases/postgresql92-server/pkg-plist-contrib
+++ b/databases/postgresql92-server/pkg-plist-contrib
@@ -2,6 +2,7 @@ bin/oid2name
bin/pg_archivecleanup
bin/pg_standby
bin/pg_upgrade
+bin/pgbench
bin/vacuumlo
lib/postgresql/_int.so
lib/postgresql/adminpack.so
diff --git a/databases/postgresql92-server/pkg-plist-server b/databases/postgresql92-server/pkg-plist-server
index 68224f4750ef..b659c30fd9e3 100644
--- a/databases/postgresql92-server/pkg-plist-server
+++ b/databases/postgresql92-server/pkg-plist-server
@@ -5,17 +5,17 @@ bin/pg_resetxlog
bin/postmaster
bin/postgres
etc/periodic/daily/502.pgsql
-lib/libpgport.a
lib/postgresql/ascii_and_mic.so
lib/postgresql/cyrillic_and_mic.so
lib/postgresql/dict_snowball.so
-lib/postgresql/euc_cn_and_mic.so
lib/postgresql/euc2004_sjis2004.so
+lib/postgresql/euc_cn_and_mic.so
lib/postgresql/euc_jp_and_sjis.so
lib/postgresql/euc_kr_and_mic.so
lib/postgresql/euc_tw_and_big5.so
lib/postgresql/latin2_and_win1250.so
lib/postgresql/latin_and_mic.so
+lib/postgresql/libpqwalreceiver.so
lib/postgresql/plpgsql.so
lib/postgresql/utf8_and_ascii.so
lib/postgresql/utf8_and_big5.so
@@ -85,6 +85,7 @@ share/postgresql/system_views.sql
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_resetxlog-9.0.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/plpgsql-9.0.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/postgres-9.0.mo
+%%GETTEXT%%share/locale/ro/LC_MESSAGES/initdb-9.0.mo
%%GETTEXT%%share/locale/ro/LC_MESSAGES/pg_controldata-9.0.mo
%%GETTEXT%%share/locale/ro/LC_MESSAGES/pg_resetxlog-9.0.mo
%%GETTEXT%%share/locale/ro/LC_MESSAGES/plpgsql-9.0.mo