aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql95-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2018-02-08 17:38:36 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2018-02-08 17:38:36 +0000
commit955b7d13bc3c846c8db5252aba9551900f2bcd5a (patch)
treed01da9b8d4a814953d381a2a12a15e65949b0e1a /databases/postgresql95-server
parenta02d810ddf2142464912bba35d6ba99ff2dc2599 (diff)
downloadports-955b7d13bc3c846c8db5252aba9551900f2bcd5a.tar.gz
ports-955b7d13bc3c846c8db5252aba9551900f2bcd5a.zip
Update to latest versions of PostgreSQL
2018-02-08 Security Update Release ================================== The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 10.2, 9.6.7, 9.5.11, 9.4.16, 9.3.21. This release fixes two security issues. This release also fixes issues with VACUUM, GIN indexes, and hash indexes that could lead to data corruption, as well as fixes for using parallel queries and logical replication. All users using the affected versions of PostgreSQL should update as soon as possible. Please see the notes on "Updating" below for any post-update steps that may be required. Please note that PostgreSQL changed its versioning scheme with the release of version 10.0, so updating to version 10.2 from 10.0 or 10.1 is considered a minor update. Security Issues --------------- Two security vulnerabilities have been fixed by this release: * CVE-2018-1052: Fix the processing of partition keys containing multiple expressions * CVE-2018-1053: Ensure that all temporary files made with "pg_upgrade" are non-world-readable Local fixes to the FreeBSD ports -------------------------------- Inform users about data checksums [1]. Make sure /usr/bin/su is used regardless of PATH settings [2]. Enable DTRACE by default [3]. PR: 214671 [1], 223157 [2], 215028 [3] Security: c602c791-0cf4-11e8-a2ec-6cc21735f730
Notes
Notes: svn path=/head/; revision=461251
Diffstat (limited to 'databases/postgresql95-server')
-rw-r--r--databases/postgresql95-server/Makefile9
-rw-r--r--databases/postgresql95-server/distinfo6
-rw-r--r--databases/postgresql95-server/files/pkg-message-server.in7
-rw-r--r--databases/postgresql95-server/files/postgresql.in6
-rw-r--r--databases/postgresql95-server/pkg-plist-server3
5 files changed, 22 insertions, 9 deletions
diff --git a/databases/postgresql95-server/Makefile b/databases/postgresql95-server/Makefile
index 879e7bdd63c5..06ce296829e7 100644
--- a/databases/postgresql95-server/Makefile
+++ b/databases/postgresql95-server/Makefile
@@ -1,8 +1,9 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
# $FreeBSD$
-DISTVERSION?= 9.5.10
+DISTVERSION?= 9.5.11
PORTREVISION= 0
+PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}${COMPONENT}
MAINTAINER?= pgsql@FreeBSD.org
@@ -18,4 +19,8 @@ INSTALL_DIRS?= src/common src/timezone src/backend \
ICU_PATCHFILE= pg-954-icu-2016-08-10.diff.gz
-.include "${.CURDIR}/../postgresql92-server/Makefile"
+PG_USER?= pgsql
+PG_GROUP?= pgsql
+PG_UID?= 70
+
+.include "${.CURDIR}/../postgresql10-server/Makefile"
diff --git a/databases/postgresql95-server/distinfo b/databases/postgresql95-server/distinfo
index 7455e3ba1cff..18f0e80dc7a4 100644
--- a/databases/postgresql95-server/distinfo
+++ b/databases/postgresql95-server/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1510172182
-SHA256 (postgresql/postgresql-9.5.10.tar.bz2) = 945d7ade094dded6b95495d8f1561a12ac9608276858ed30adf3c3658275f281
-SIZE (postgresql/postgresql-9.5.10.tar.bz2) = 18701419
+TIMESTAMP = 1517868536
+SHA256 (postgresql/postgresql-9.5.11.tar.bz2) = 8182cd74e27a75ae39166b2603b5014f4272855b4101b40819761b853a77c8dd
+SIZE (postgresql/postgresql-9.5.11.tar.bz2) = 18572811
SHA256 (postgresql/pg-954-icu-2016-08-10.diff.gz) = 5fa083ec38087d6a0961642208f012e902221270708b919b92e9eedaa755e365
SIZE (postgresql/pg-954-icu-2016-08-10.diff.gz) = 5952
diff --git a/databases/postgresql95-server/files/pkg-message-server.in b/databases/postgresql95-server/files/pkg-message-server.in
index d161fcb82f66..8df5b8198903 100644
--- a/databases/postgresql95-server/files/pkg-message-server.in
+++ b/databases/postgresql95-server/files/pkg-message-server.in
@@ -50,6 +50,13 @@ For postmaster settings, see ~pgsql/data/postgresql.conf
NB. FreeBSD's PostgreSQL port logs to syslog by default
See ~pgsql/data/postgresql.conf for more info
+NB. If you're not using a checksumming filesystem like ZFS, you might
+ wish to enable data checksumming. It can only be enabled during
+ the initdb phase, by adding the "--data-checksums" flag to
+ the postgres_initdb_flags rcvar. Check the initdb(1) manpage
+ for more info and make sure you understand the performance
+ implications.
+
======================================================================
To run PostgreSQL at startup, add
diff --git a/databases/postgresql95-server/files/postgresql.in b/databases/postgresql95-server/files/postgresql.in
index b6724571bd29..f6ea340f7f0f 100644
--- a/databases/postgresql95-server/files/postgresql.in
+++ b/databases/postgresql95-server/files/postgresql.in
@@ -50,6 +50,8 @@ status_cmd="postgresql_command status"
initdb_cmd="postgresql_initdb"
+su_cmd="/usr/bin/su"
+
if [ -n "$2" ]; then
profile="$2"
if [ "x${postgresql_profiles}" != "x" ]; then
@@ -103,12 +105,12 @@ command_args="-D ${postgresql_data} ${postgresql_flags}"
postgresql_command()
{
- su -l ${postgresql_user} -c "exec ${command} ${command_args} ${rc_arg}"
+ ${su_cmd} -l ${postgresql_user} -c "exec ${command} ${command_args} ${rc_arg}"
}
postgresql_initdb()
{
- su -l -c ${postgresql_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data} -U ${postgresql_user}"
+ ${su_cmd} -l -c ${postgresql_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data} -U ${postgresql_user}"
}
run_rc_command "$1"
diff --git a/databases/postgresql95-server/pkg-plist-server b/databases/postgresql95-server/pkg-plist-server
index aa4288cb155a..7137a16e8a67 100644
--- a/databases/postgresql95-server/pkg-plist-server
+++ b/databases/postgresql95-server/pkg-plist-server
@@ -110,7 +110,7 @@ lib/libpgcommon.a
%%NLS%%share/locale/ko/LC_MESSAGES/pg_ctl-9.5.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_resetxlog-9.5.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_rewind-9.5.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/pl%%PG_USER%%-9.5.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/plpgsql-9.5.mo
%%NLS%%share/locale/pl/LC_MESSAGES/initdb-9.5.mo
%%NLS%%share/locale/pl/LC_MESSAGES/pg_basebackup-9.5.mo
%%NLS%%share/locale/pl/LC_MESSAGES/pg_controldata-9.5.mo
@@ -736,7 +736,6 @@ lib/libpgcommon.a
%%TZDATA%%%%DATADIR%%/timezone/US/Michigan
%%TZDATA%%%%DATADIR%%/timezone/US/Mountain
%%TZDATA%%%%DATADIR%%/timezone/US/Pacific
-%%TZDATA%%%%DATADIR%%/timezone/US/Pacific-New
%%TZDATA%%%%DATADIR%%/timezone/US/Samoa
%%TZDATA%%%%DATADIR%%/timezone/UTC
%%TZDATA%%%%DATADIR%%/timezone/Universal