aboutsummaryrefslogtreecommitdiff
path: root/databases/pxtools
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-09-29 02:55:24 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-09-29 02:55:24 +0000
commitef82274f652134e6cbf0b2d8a299b445473ac926 (patch)
tree700628a5769b58a90958a5d6e34633c3b0882e77 /databases/pxtools
parentbe8e5d8733a0d1535ea2c7fd62fd78abae8af519 (diff)
downloadports-ef82274f652134e6cbf0b2d8a299b445473ac926.tar.gz
ports-ef82274f652134e6cbf0b2d8a299b445473ac926.zip
Add dependency on gettext, since there appears to no longer be an
included gettext in this port.
Notes
Notes: svn path=/head/; revision=67208
Diffstat (limited to 'databases/pxtools')
-rw-r--r--databases/pxtools/Makefile4
-rw-r--r--databases/pxtools/files/patch-src::Makefile.in13
2 files changed, 13 insertions, 4 deletions
diff --git a/databases/pxtools/Makefile b/databases/pxtools/Makefile
index 93e3b691844f..00996290e32d 100644
--- a/databases/pxtools/Makefile
+++ b/databases/pxtools/Makefile
@@ -12,11 +12,11 @@ MASTER_SITES= http://jan.kneschke.de/projects/pxtools/download/
MAINTAINER= jedgar@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ intl.4:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-included-gettext
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
diff --git a/databases/pxtools/files/patch-src::Makefile.in b/databases/pxtools/files/patch-src::Makefile.in
index cb1458875c50..41b4fa8960f1 100644
--- a/databases/pxtools/files/patch-src::Makefile.in
+++ b/databases/pxtools/files/patch-src::Makefile.in
@@ -1,5 +1,5 @@
---- src/Makefile.in.orig Tue Jul 16 10:12:57 2002
-+++ src/Makefile.in Fri Sep 6 11:19:29 2002
+--- src/Makefile.in.orig Tue Jul 16 07:12:57 2002
++++ src/Makefile.in Sat Sep 28 20:02:35 2002
@@ -140,7 +140,7 @@
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
CPPFLAGS = @CPPFLAGS@
@@ -9,3 +9,12 @@
depcomp = $(SHELL) $(top_srcdir)/depcomp
@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/pxconvert.Po $(DEPDIR)/pxcsvdump.Po \
@AMDEP_TRUE@ $(DEPDIR)/pxinfo.Po $(DEPDIR)/pxparse.Po \
+@@ -195,7 +195,7 @@
+ $(LINK) $(pxcsvdump_LDFLAGS) $(pxcsvdump_OBJECTS) $(pxcsvdump_LDADD) $(LIBS)
+ pxinfo$(EXEEXT): $(pxinfo_OBJECTS) $(pxinfo_DEPENDENCIES)
+ @rm -f pxinfo$(EXEEXT)
+- $(LINK) $(pxinfo_LDFLAGS) $(pxinfo_OBJECTS) $(pxinfo_LDADD) $(LIBS)
++ $(LINK) $(pxinfo_LDFLAGS) $(pxinfo_OBJECTS) $(pxinfo_LDADD) $(LIBS) $(INTLLIBS)
+ pxsqldump$(EXEEXT): $(pxsqldump_OBJECTS) $(pxsqldump_DEPENDENCIES)
+ @rm -f pxsqldump$(EXEEXT)
+ $(LINK) $(pxsqldump_LDFLAGS) $(pxsqldump_OBJECTS) $(pxsqldump_LDADD) $(LIBS)