aboutsummaryrefslogtreecommitdiff
path: root/databases/py-aiomysql
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-06 20:42:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-06 20:42:55 +0000
commit1cbc5026a8d3c10a9ba37f07b60dfe2341771571 (patch)
tree0706221f316ef3c7826e173173486806e1dc035b /databases/py-aiomysql
parent23f68ee7c3fd9ab9c9c819d121fe1ee750eae003 (diff)
downloadports-1cbc5026a8d3c10a9ba37f07b60dfe2341771571.tar.gz
ports-1cbc5026a8d3c10a9ba37f07b60dfe2341771571.zip
Add py-aiomysql 0.0.21
aiomysql is a "driver" for accessing a MySQL database from the asyncio (PEP-3156/tulip) framework. It depends on and reuses most parts of PyMySQL . aiomysql tries to be like awesome aiopg library and preserve same api, look and feel. Internally aiomysql is copy of PyMySQL, underlying io calls switched to async, basically yield from and asyncio.coroutine added in proper places)). sqlalchemy support ported from aiopg. WWW: https://github.com/aio-libs/aiomysql
Notes
Notes: svn path=/head/; revision=564246
Diffstat (limited to 'databases/py-aiomysql')
-rw-r--r--databases/py-aiomysql/Makefile23
-rw-r--r--databases/py-aiomysql/distinfo3
-rw-r--r--databases/py-aiomysql/files/patch-setup.py11
-rw-r--r--databases/py-aiomysql/pkg-descr10
4 files changed, 47 insertions, 0 deletions
diff --git a/databases/py-aiomysql/Makefile b/databases/py-aiomysql/Makefile
new file mode 100644
index 000000000000..ce19c31c0b46
--- /dev/null
+++ b/databases/py-aiomysql/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aiomysql
+PORTVERSION= 0.0.21
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= MySQL driver for asyncio
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymysql>=0.9:databases/py-pymysql@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-aiomysql/distinfo b/databases/py-aiomysql/distinfo
new file mode 100644
index 000000000000..e54ceececd53
--- /dev/null
+++ b/databases/py-aiomysql/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1612519091
+SHA256 (aiomysql-0.0.21.tar.gz) = 811569c0db118dd2685f0878f5cebf17a11e89a995fa14261d5fa0254113842c
+SIZE (aiomysql-0.0.21.tar.gz) = 61286
diff --git a/databases/py-aiomysql/files/patch-setup.py b/databases/py-aiomysql/files/patch-setup.py
new file mode 100644
index 000000000000..56904b48871d
--- /dev/null
+++ b/databases/py-aiomysql/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-11-26 16:45:41 UTC
++++ setup.py
+@@ -4,7 +4,7 @@ import sys
+ from setuptools import setup, find_packages
+
+
+-install_requires = ['PyMySQL>=0.9,<=0.9.3']
++install_requires = ['PyMySQL>=0.9']
+
+ PY_VER = sys.version_info
+
diff --git a/databases/py-aiomysql/pkg-descr b/databases/py-aiomysql/pkg-descr
new file mode 100644
index 000000000000..73047421865f
--- /dev/null
+++ b/databases/py-aiomysql/pkg-descr
@@ -0,0 +1,10 @@
+aiomysql is a "driver" for accessing a MySQL database from the asyncio
+(PEP-3156/tulip) framework. It depends on and reuses most parts of PyMySQL .
+aiomysql tries to be like awesome aiopg library and preserve same api, look and
+feel.
+
+Internally aiomysql is copy of PyMySQL, underlying io calls switched to async,
+basically yield from and asyncio.coroutine added in proper places)). sqlalchemy
+support ported from aiopg.
+
+WWW: https://github.com/aio-libs/aiomysql