aboutsummaryrefslogtreecommitdiff
path: root/databases/py-aioredis
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2018-07-07 09:10:19 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2018-07-07 09:10:19 +0000
commitbf50ed1ab04da3287d2efc1bb1aca6ad4bb13d90 (patch)
treee138a9020a9f2e4171e59eb8d15d010f79dbeb0d /databases/py-aioredis
parente07fae55fe710a241c5bdea7ddb52629b8e3eb2a (diff)
downloadports-bf50ed1ab04da3287d2efc1bb1aca6ad4bb13d90.tar.gz
ports-bf50ed1ab04da3287d2efc1bb1aca6ad4bb13d90.zip
databases/py-aioredis: Add missing dependencies
Notes
Notes: svn path=/head/; revision=474065
Diffstat (limited to 'databases/py-aioredis')
-rw-r--r--databases/py-aioredis/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/databases/py-aioredis/Makefile b/databases/py-aioredis/Makefile
index 123d3fee4380..86878f988035 100644
--- a/databases/py-aioredis/Makefile
+++ b/databases/py-aioredis/Makefile
@@ -3,6 +3,7 @@
PORTNAME= aioredis
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,13 @@ COMMENT= Python asyncio based Redis client library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libhiredis.so:databases/hiredis
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}async_timeout>0:devel/py-async_timeout@${PY_FLAVOR}
+
+OPTIONS_DEFINE= HIREDIS
+
+HIREDIS_DESC= High performance response parser (via hiredis)
+
+HIREDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hiredis>0:databases/py-hiredis@${PY_FLAVOR}
USES= python:3.5+
USE_PYTHON= distutils autoplist