aboutsummaryrefslogtreecommitdiff
path: root/databases/py-fakeredis
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2017-01-07 12:27:45 +0000
committerRene Ladan <rene@FreeBSD.org>2017-01-07 12:27:45 +0000
commitf6da41594d56783236f19c1f9e9d189ec1ea7735 (patch)
tree3d44103957f1b9cd51c72988c6ea339a25519756 /databases/py-fakeredis
parenta5aedafd1a6f6f654555b1e3755b8f79f3d1f189 (diff)
downloadports-f6da41594d56783236f19c1f9e9d189ec1ea7735.tar.gz
ports-f6da41594d56783236f19c1f9e9d189ec1ea7735.zip
fakeredis is a pure python implementation of the redis-py python client that
simulates talking to a redis server. This was created for a single purpose: to write unittests. Setting up redis is not hard, but many times you want to write unittests that do not talk to an external server (such as redis). This module now allows tests to simply use this module as a reasonable substitute for redis. WWW: https://github.com/jamesls/fakeredis
Notes
Notes: svn path=/head/; revision=430782
Diffstat (limited to 'databases/py-fakeredis')
-rw-r--r--databases/py-fakeredis/Makefile21
-rw-r--r--databases/py-fakeredis/distinfo3
-rw-r--r--databases/py-fakeredis/pkg-descr8
3 files changed, 32 insertions, 0 deletions
diff --git a/databases/py-fakeredis/Makefile b/databases/py-fakeredis/Makefile
new file mode 100644
index 000000000000..9c8925e4c050
--- /dev/null
+++ b/databases/py-fakeredis/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= fakeredis
+PORTVERSION= 0.8.2
+CATEGORIES= databases
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rene@FreeBSD.org
+COMMENT= Fake version of databases/py-redis for unit testing
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>=0:databases/py-redis
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-fakeredis/distinfo b/databases/py-fakeredis/distinfo
new file mode 100644
index 000000000000..464d26e51e1b
--- /dev/null
+++ b/databases/py-fakeredis/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483784764
+SHA256 (fakeredis-0.8.2.tar.gz) = 39cd454c49b6e31233be41a8b111a6c00278434af3c4d49dd7cafb352454cc7e
+SIZE (fakeredis-0.8.2.tar.gz) = 21057
diff --git a/databases/py-fakeredis/pkg-descr b/databases/py-fakeredis/pkg-descr
new file mode 100644
index 000000000000..4b3e3e1c27bd
--- /dev/null
+++ b/databases/py-fakeredis/pkg-descr
@@ -0,0 +1,8 @@
+fakeredis is a pure python implementation of the redis-py python client that
+simulates talking to a redis server. This was created for a single purpose:
+to write unittests. Setting up redis is not hard, but many times you want to
+write unittests that do not talk to an external server (such as redis). This
+module now allows tests to simply use this module as a reasonable substitute
+for redis.
+
+WWW: https://github.com/jamesls/fakeredis