aboutsummaryrefslogtreecommitdiff
path: root/databases/py-hiredis
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-05-07 08:18:11 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-05-07 08:18:11 +0000
commitfd876ca3f69447d1cc55fc7f2c54992c21b11868 (patch)
treef04911c358a7e704f9c53c0eeb6795f3a06ca28f /databases/py-hiredis
parentc61a1584faaa397ab136ef357a21943818060c57 (diff)
downloadports-fd876ca3f69447d1cc55fc7f2c54992c21b11868.tar.gz
ports-fd876ca3f69447d1cc55fc7f2c54992c21b11868.zip
Upgrade to 0.2.0 and fix linking with libhiredis.
PR: 199997 Submitted by: olgeni Approved by: maintainer
Notes
Notes: svn path=/head/; revision=385599
Diffstat (limited to 'databases/py-hiredis')
-rw-r--r--databases/py-hiredis/Makefile2
-rw-r--r--databases/py-hiredis/distinfo4
-rw-r--r--databases/py-hiredis/files/patch-setup.py11
3 files changed, 9 insertions, 8 deletions
diff --git a/databases/py-hiredis/Makefile b/databases/py-hiredis/Makefile
index fe7e0213335a..c9d058a8fe44 100644
--- a/databases/py-hiredis/Makefile
+++ b/databases/py-hiredis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hiredis
-PORTVERSION= 0.1.2
+PORTVERSION= 0.2.0
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/py-hiredis/distinfo b/databases/py-hiredis/distinfo
index dd4868b600f3..819017feb32e 100644
--- a/databases/py-hiredis/distinfo
+++ b/databases/py-hiredis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hiredis-0.1.2.tar.gz) = c44df954d9dcc9f57682bf8fabf172a112edf53ff35bb5ce8f8fff1b1985abb1
-SIZE (hiredis-0.1.2.tar.gz) = 36951
+SHA256 (hiredis-0.2.0.tar.gz) = ca958e13128e49674aa4a96f02746f5de5973f39b57297b84d59fd44d314d5b5
+SIZE (hiredis-0.2.0.tar.gz) = 46113
diff --git a/databases/py-hiredis/files/patch-setup.py b/databases/py-hiredis/files/patch-setup.py
index af2b2ac9e781..28a5f8da45e4 100644
--- a/databases/py-hiredis/files/patch-setup.py
+++ b/databases/py-hiredis/files/patch-setup.py
@@ -1,16 +1,17 @@
---- ./setup.py.orig 2014-01-06 19:08:27.000000000 +0400
-+++ ./setup.py 2014-01-07 15:36:44.000000000 +0400
-@@ -41,7 +41,8 @@
+--- setup.py.orig 2015-04-03 14:08:45 UTC
++++ setup.py
+@@ -45,7 +45,9 @@ lib = ("hiredis_for_hiredis_py", {
ext = Extension("hiredis.hiredis",
sources=glob.glob("src/*.c"),
- include_dirs=["vendor"])
+ include_dirs=["%%LOCALBASE%%/include"],
-+ library_dirs=["%%LOCALBASE%%/lib"],)
++ library_dirs=["%%LOCALBASE%%/lib"],
++ libraries=["hiredis"],)
setup(
name="hiredis",
-@@ -53,7 +54,6 @@
+@@ -57,7 +59,6 @@ setup(
keywords=["Redis"],
license="BSD",
packages=["hiredis"],