aboutsummaryrefslogtreecommitdiff
path: root/databases/py-peewee_migrate
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-12-22 20:13:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-12-22 20:13:45 +0000
commit31517c8ff16f3cae3e1744e6553b2b2933c2d9e6 (patch)
tree89caeef2c8d36308eb59c034707e174314f8951a /databases/py-peewee_migrate
parent3428ea2f56eacd0b458cecc8e21936f26116cb71 (diff)
downloadports-31517c8ff16f3cae3e1744e6553b2b2933c2d9e6.tar.gz
ports-31517c8ff16f3cae3e1744e6553b2b2933c2d9e6.zip
New port: databases/py-peewee-migrate: Simple migration engine for Peewee
WWW: https://github.com/klen/peewee_migrate PR: 242808 Submitted by: Goran Mekić <meka@tilda.center>
Notes
Notes: svn path=/head/; revision=520658
Diffstat (limited to 'databases/py-peewee_migrate')
-rw-r--r--databases/py-peewee_migrate/Makefile35
-rw-r--r--databases/py-peewee_migrate/distinfo3
-rw-r--r--databases/py-peewee_migrate/pkg-descr3
3 files changed, 41 insertions, 0 deletions
diff --git a/databases/py-peewee_migrate/Makefile b/databases/py-peewee_migrate/Makefile
new file mode 100644
index 000000000000..5e79fbbe858c
--- /dev/null
+++ b/databases/py-peewee_migrate/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= peewee_migrate
+PORTVERSION= 1.1.6
+CATEGORIES= databases devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Simple migration engine for Peewee
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}peewee>=0:databases/py-peewee@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psycopg2>=0:databases/py-psycopg2@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes # tests not shipped with sdist
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= klen
+GH_TAGNAME= ${PORTVERSION}
+TEST_ENV= PYTHONPATH=${WRKSRC}/src
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>
diff --git a/databases/py-peewee_migrate/distinfo b/databases/py-peewee_migrate/distinfo
new file mode 100644
index 000000000000..6c250272136e
--- /dev/null
+++ b/databases/py-peewee_migrate/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577033890
+SHA256 (klen-peewee_migrate-1.1.6_GH0.tar.gz) = bdd96c115ba4438f214d899753f17641fdba445c71a5f4cda97d091d9c5ec90e
+SIZE (klen-peewee_migrate-1.1.6_GH0.tar.gz) = 20853
diff --git a/databases/py-peewee_migrate/pkg-descr b/databases/py-peewee_migrate/pkg-descr
new file mode 100644
index 000000000000..2a6adde0b695
--- /dev/null
+++ b/databases/py-peewee_migrate/pkg-descr
@@ -0,0 +1,3 @@
+Simple migration engine for Peewee
+
+WWW: https://github.com/klen/peewee_migrate