aboutsummaryrefslogtreecommitdiff
path: root/databases/py-postgresql
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-10 12:20:32 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-10 12:20:32 +0000
commit501cd8e801385cd409de8a283e8abe2225f3b86a (patch)
tree989e3925cd281bf2cbac701fa66c1bd1ec7c3300 /databases/py-postgresql
parent39593d116b2d1833cfbbc9c1c7f7ed0f890d5191 (diff)
downloadports-501cd8e801385cd409de8a283e8abe2225f3b86a.tar.gz
ports-501cd8e801385cd409de8a283e8abe2225f3b86a.zip
- update to 1.1.0
- trim Makefile header completely (requested by maintainer) - add CHEESESHOP and make it primary MASTER_SITE, because other locations doesn't hold the new release yet - remove one distfile mirror (requested by maintainer) - add LICENSE (BSD) - replace USE_XZ with USE_ZIP, since it was changed upstream - tune PYDISTUTILS_PKGNAME - move python32 plist stuff into separate file changelog: http://pgfoundry.org/pipermail/python-general/2012-October/001003.html PR: 172544 (but I can't see it in GNATS because of hub transition) Submitted by: rm (myself) Approved by: Volodymyr Kostyrko <c.kworr at gmail dot com> (maintainer, by mail)
Notes
Notes: svn path=/head/; revision=305647
Diffstat (limited to 'databases/py-postgresql')
-rw-r--r--databases/py-postgresql/Makefile33
-rw-r--r--databases/py-postgresql/distinfo4
-rw-r--r--databases/py-postgresql/files/py3k-fix-pkg-plist.inc14
-rw-r--r--databases/py-postgresql/pkg-plist49
4 files changed, 24 insertions, 76 deletions
diff --git a/databases/py-postgresql/Makefile b/databases/py-postgresql/Makefile
index dfb1c5e3b839..453eade75b3b 100644
--- a/databases/py-postgresql/Makefile
+++ b/databases/py-postgresql/Makefile
@@ -1,15 +1,10 @@
-# New ports collection makefile for: py-postgresql
-# Date created: 15 August 2009
-# Whom: Volodymyr Kostyrko <c.kworr@gmail.com>
-#
# $FreeBSD$
-#
PORTNAME= postgresql
-PORTVERSION= 1.0.4
+PORTVERSION= 1.1.0
CATEGORIES= databases python
-MASTER_SITES= http://python.projects.postgresql.org/files/ \
- http://limbo.xim.bz/distfiles/
+MASTER_SITES= CHEESESHOP \
+ http://python.projects.postgresql.org/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= postgresql
@@ -17,30 +12,18 @@ DIST_SUBDIR= postgresql
MAINTAINER= c.kworr@gmail.com
COMMENT= Python 3 compatible PostgreSQL database driver and tools
-USE_XZ= yes
+LICENSE= BSD
+
+USE_ZIP= yes
USE_PGSQL= yes
USE_PYTHON= 3.1+
USE_PYDISTUTILS= yes
-
-PYDISTUTILS_EGGINFO= py_${PYDISTUTILS_PKGNAME:C/[^A-Za-z0-9.]+/_/g}-${PYDISTUTILS_PKGVERSION:C/[^A-Za-z0-9.]+/_/g}-${PYTHON_VERSION:S/thon//}.egg-info
+PYDISTUTILS_PKGNAME= py_${PORTNAME}
.include <bsd.port.pre.mk>
-# When Python version is 3.2+ we rewrite all the filenames
-# of TMPPLIST that end with .py[co], so that they conform
-# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
.if ${PYTHON_REL} >= 320
-PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
-add-plist-post:
- @${AWK} '\
- /\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
- /^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
- {print} \
- END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
- ' \
- pc="__pycache__" mt="$$(${PYMAGICTAG})" sp="${PYTHON_SITELIBDIR:S,${PYTHONBASE}/,,g}" \
- ${TMPPLIST} > ${TMPPLIST}.pyc_tmp
- @${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
+.include "${FILESDIR}/py3k-fix-pkg-plist.inc"
.endif
.include <bsd.port.post.mk>
diff --git a/databases/py-postgresql/distinfo b/databases/py-postgresql/distinfo
index 5632f63ec40c..ef7338bb8f50 100644
--- a/databases/py-postgresql/distinfo
+++ b/databases/py-postgresql/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postgresql/py-postgresql-1.0.4.tar.xz) = d0ed0a98a33c598d416a3c713befcdedb14f37b961c6985547a120f8830a41fe
-SIZE (postgresql/py-postgresql-1.0.4.tar.xz) = 605228
+SHA256 (postgresql/py-postgresql-1.1.0.zip) = 4bae6e15bf0be03294240acc5b27f5aa2d9649188bc4528cd5b5512582e0ea93
+SIZE (postgresql/py-postgresql-1.1.0.zip) = 254537
diff --git a/databases/py-postgresql/files/py3k-fix-pkg-plist.inc b/databases/py-postgresql/files/py3k-fix-pkg-plist.inc
new file mode 100644
index 000000000000..93acb972e248
--- /dev/null
+++ b/databases/py-postgresql/files/py3k-fix-pkg-plist.inc
@@ -0,0 +1,14 @@
+# When Python version is 3.2+ we rewrite all the filenames
+# of TMPPLIST that end with .py[co], so that they conform
+# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
+PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
+add-plist-post:
+ @${AWK} '\
+ /\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
+ /^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
+ {print} \
+ END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
+ ' \
+ pc="__pycache__" mt="$$(${PYMAGICTAG})" sp="${PYTHON_SITELIBDIR:S,${PYTHONBASE}/,,g}" \
+ ${TMPPLIST} > ${TMPPLIST}.pyc_tmp
+ @${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
diff --git a/databases/py-postgresql/pkg-plist b/databases/py-postgresql/pkg-plist
index be43c113966b..9aabc77d88d6 100644
--- a/databases/py-postgresql/pkg-plist
+++ b/databases/py-postgresql/pkg-plist
@@ -26,55 +26,6 @@
%%PYTHON_SITELIBDIR%%/postgresql/copyman.py
%%PYTHON_SITELIBDIR%%/postgresql/copyman.pyc
%%PYTHON_SITELIBDIR%%/postgresql/copyman.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/admin.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/admin.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/admin.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/admin.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/alock.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/alock.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/alock.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/alock.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/bin.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/bin.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/bin.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/bin.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/changes-v1.0.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/changes.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/changes.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/changes.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/clientparameters.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/clientparameters.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/clientparameters.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/clientparameters.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/cluster.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/cluster.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/cluster.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/cluster.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/copyman.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/copyman.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/copyman.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/copyman.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/driver.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/driver.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/driver.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/driver.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/gotchas.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/gotchas.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/gotchas.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/gotchas.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/index.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/index.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/index.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/index.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/lib.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/lib.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/lib.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/lib.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/notifyman.py
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/notifyman.pyc
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/notifyman.pyo
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/notifyman.txt
-%%PYTHON_SITELIBDIR%%/postgresql/documentation/modules.txt
%%PYTHON_SITELIBDIR%%/postgresql/documentation/__init__.py
%%PYTHON_SITELIBDIR%%/postgresql/documentation/__init__.pyc
%%PYTHON_SITELIBDIR%%/postgresql/documentation/__init__.pyo