aboutsummaryrefslogtreecommitdiff
path: root/databases/py-pymemcache
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-05-09 15:15:00 +0000
committerSteve Wills <swills@FreeBSD.org>2020-05-09 15:15:00 +0000
commit6a1c5737aa50cce94a17e665b42da622906ca16a (patch)
tree7fcb05b66948c01d5b5997a46d844ac43c9d07f6 /databases/py-pymemcache
parentaadc5d91893c1cce47bcb167983b105e08bb3798 (diff)
downloadports-6a1c5737aa50cce94a17e665b42da622906ca16a.tar.gz
ports-6a1c5737aa50cce94a17e665b42da622906ca16a.zip
databases/py-pymemcache: create port
A comprehensive, fast, pure-Python memcached client. pymemcache supports the following features: * Complete implementation of the memcached text protocol. * Configurable timeouts for socket connect and send/recv calls. * Access to the "noreply" flag, which can significantly increase the speed of writes. * Flexible, modular and simple approach to serialization and deserialization. * The (optional) ability to treat network and memcached errors as cache misses. WWW: https://github.com/pinterest/pymemcache PR: 246314 Submitted by: Alessandro Sagratini <ale_sagra@hotmail.com>
Notes
Notes: svn path=/head/; revision=534780
Diffstat (limited to 'databases/py-pymemcache')
-rw-r--r--databases/py-pymemcache/Makefile27
-rw-r--r--databases/py-pymemcache/distinfo3
-rw-r--r--databases/py-pymemcache/pkg-descr13
3 files changed, 43 insertions, 0 deletions
diff --git a/databases/py-pymemcache/Makefile b/databases/py-pymemcache/Makefile
new file mode 100644
index 000000000000..b7b1dba939e4
--- /dev/null
+++ b/databases/py-pymemcache/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= pymemcache
+PORTVERSION= 3.1.1
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ale_sagra@hotmail.com
+COMMENT= Comprehensive, fast, pure-Python memcached client
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+DEVELOPER= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.mk>
diff --git a/databases/py-pymemcache/distinfo b/databases/py-pymemcache/distinfo
new file mode 100644
index 000000000000..593505e26688
--- /dev/null
+++ b/databases/py-pymemcache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588673573
+SHA256 (pymemcache-3.1.1.tar.gz) = 39cb4ed728fad0d71386730898b467d3d56994fcabfea324d8b2e743fa158bff
+SIZE (pymemcache-3.1.1.tar.gz) = 44464
diff --git a/databases/py-pymemcache/pkg-descr b/databases/py-pymemcache/pkg-descr
new file mode 100644
index 000000000000..b72248edfdc5
--- /dev/null
+++ b/databases/py-pymemcache/pkg-descr
@@ -0,0 +1,13 @@
+A comprehensive, fast, pure-Python memcached client.
+
+pymemcache supports the following features:
+
+ * Complete implementation of the memcached text protocol.
+ * Configurable timeouts for socket connect and send/recv calls.
+ * Access to the "noreply" flag, which can significantly increase the speed of
+ writes.
+ * Flexible, modular and simple approach to serialization and deserialization.
+ * The (optional) ability to treat network and memcached errors as cache
+ misses.
+
+WWW: https://github.com/pinterest/pymemcache