aboutsummaryrefslogtreecommitdiff
path: root/databases/py-pymongo
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-09 20:50:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-09 20:51:35 +0000
commit95e2a2c31fc5eb95329a897a78a01efa302c341f (patch)
treeb9f766046f584c0402feab130a2bbcf5534439d5 /databases/py-pymongo
parent10f64442bc23c317310579b5a78b0ff6466a53ec (diff)
downloadports-95e2a2c31fc5eb95329a897a78a01efa302c341f.tar.gz
ports-95e2a2c31fc5eb95329a897a78a01efa302c341f.zip
Diffstat (limited to 'databases/py-pymongo')
-rw-r--r--databases/py-pymongo/Makefile22
-rw-r--r--databases/py-pymongo/distinfo3
-rw-r--r--databases/py-pymongo/pkg-descr4
3 files changed, 29 insertions, 0 deletions
diff --git a/databases/py-pymongo/Makefile b/databases/py-pymongo/Makefile
new file mode 100644
index 000000000000..d24ea207d8bb
--- /dev/null
+++ b/databases/py-pymongo/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= pymongo
+PORTVERSION= 3.12.3
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= Python driver for MongoDB
+WWW= https://github.com/mongodb/mongo-python-driver
+
+LICENSE= APACHE20
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+CONFLICTS_INSTALL= py[0-9][0-9]-pymongo28
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/bson/_cbson${PYTHON_EXT_SUFFIX}.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pymongo/_cmessage${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/databases/py-pymongo/distinfo b/databases/py-pymongo/distinfo
new file mode 100644
index 000000000000..36d003c535f4
--- /dev/null
+++ b/databases/py-pymongo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655299566
+SHA256 (pymongo-3.12.3.tar.gz) = 0a89cadc0062a5e53664dde043f6c097172b8c1c5f0094490095282ff9995a5f
+SIZE (pymongo-3.12.3.tar.gz) = 821234
diff --git a/databases/py-pymongo/pkg-descr b/databases/py-pymongo/pkg-descr
new file mode 100644
index 000000000000..4a2444db4737
--- /dev/null
+++ b/databases/py-pymongo/pkg-descr
@@ -0,0 +1,4 @@
+The PyMongo distribution contains tools for interacting with
+the Mongo database from Python. The pymongo package is a native
+Python driver for the Mongo database. The gridfs package is a
+gridfs implementation on top of pymongo.