aboutsummaryrefslogtreecommitdiff
path: root/databases/py-python-binary-memcached/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-08-30 07:12:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-08-30 07:12:37 +0000
commit359ea5d1be9dc49afa44dbde0c588be524b2d499 (patch)
tree9857b4f307ccfa3c6932b4146bcfcc1cb08e2a88 /databases/py-python-binary-memcached/Makefile
parentafe72edb94c11ab720d18e06d9f7de43bbea5ff1 (diff)
downloadports-359ea5d1be9dc49afa44dbde0c588be524b2d499.tar.gz
ports-359ea5d1be9dc49afa44dbde0c588be524b2d499.zip
Notes
Diffstat (limited to 'databases/py-python-binary-memcached/Makefile')
-rw-r--r--databases/py-python-binary-memcached/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/databases/py-python-binary-memcached/Makefile b/databases/py-python-binary-memcached/Makefile
new file mode 100644
index 000000000000..6a597b540c0e
--- /dev/null
+++ b/databases/py-python-binary-memcached/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-binary-memcached
+PORTVERSION= 0.30.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pure python module to access memcached via its binary protocol
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uhashring>=0:security/py-uhashring@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>