aboutsummaryrefslogtreecommitdiff
path: root/databases/py-qt5-sql
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 21:56:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 21:56:50 +0000
commit5b3f3dd953448e0ec3ddc609dbf53a005662635d (patch)
treec8ea48f297bee52a8d84f4ec84da2d9fa23078a5 /databases/py-qt5-sql
parent7f63a1808f185107b013d2e350c33370099f37b3 (diff)
downloadports-5b3f3dd953448e0ec3ddc609dbf53a005662635d.tar.gz
ports-5b3f3dd953448e0ec3ddc609dbf53a005662635d.zip
At very long last land PyQt5 5.5.1 ports.
Add the required bits to Uses/pyqt.mk along with all the PyQt5 ports. Thankfully this commit is mostly adding new ports, as the hard work was already done in r403297 and r403662. Huge kudos to Tobias Berner <tcberner@gmail.com> and, most importantly, Guido Falsi (madpilot@) for their initial work on these ports (see D2910 in Phabricator for an earlier version of the PyQt5 patch set). PR: 204672
Notes
Notes: svn path=/head/; revision=403693
Diffstat (limited to 'databases/py-qt5-sql')
-rw-r--r--databases/py-qt5-sql/Makefile27
-rw-r--r--databases/py-qt5-sql/pkg-descr4
-rw-r--r--databases/py-qt5-sql/pkg-plist16
3 files changed, 47 insertions, 0 deletions
diff --git a/databases/py-qt5-sql/Makefile b/databases/py-qt5-sql/Makefile
new file mode 100644
index 000000000000..b5025707b88a
--- /dev/null
+++ b/databases/py-qt5-sql/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= sql
+CATEGORIES= databases devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtSql module
+
+CONFIGURE_ARGS= --enable QtSql
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run widgets_run
+USE_QT5= core gui sql widgets buildtools_build qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtSql API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/databases/py-qt5-sql/pkg-descr b/databases/py-qt5-sql/pkg-descr
new file mode 100644
index 000000000000..d1a42d528ef5
--- /dev/null
+++ b/databases/py-qt5-sql/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtSql module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/databases/py-qt5-sql/pkg-plist b/databases/py-qt5-sql/pkg-plist
new file mode 100644
index 000000000000..0cee73192b42
--- /dev/null
+++ b/databases/py-qt5-sql/pkg-plist
@@ -0,0 +1,16 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtSql.so
+%%PYQT_SIPDIR%%/QtSql/QtSqlmod.sip
+%%PYQT_SIPDIR%%/QtSql/qsql.sip
+%%PYQT_SIPDIR%%/QtSql/qsqldatabase.sip
+%%PYQT_SIPDIR%%/QtSql/qsqldriver.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlerror.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlfield.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlindex.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlquery.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlquerymodel.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlrecord.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlrelationaldelegate.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlrelationaltablemodel.sip
+%%PYQT_SIPDIR%%/QtSql/qsqlresult.sip
+%%PYQT_SIPDIR%%/QtSql/qsqltablemodel.sip
+%%API%%share/qt5/qsci/api/python/QtSql.api