aboutsummaryrefslogtreecommitdiff
path: root/databases/py-redis
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-06-16 09:10:19 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-06-16 09:10:19 +0000
commit01020d179e912c12598e176d1ba18d0d6a7eb528 (patch)
tree1abe007536c3e3c8de89efba6cff7e4a90b55dbe /databases/py-redis
parentb3e8464e842ff51b0b24b18d7d62664b70c76b48 (diff)
downloadports-01020d179e912c12598e176d1ba18d0d6a7eb528.tar.gz
ports-01020d179e912c12598e176d1ba18d0d6a7eb528.zip
databases/py-redis: Update to 2.7.6
- Update to 2.7.6 - Update setup.py patch Changes: * 2.7.6 * Added CONFIG RESETSTAT command. Thanks Yossi Gottlieb. * Fixed a bug introduced in 2.7.3 that caused issues with script objects and pipelines. Thanks Carpentier Pierre-Francois. * Converted redis-py's test suite to use the awesome py.test library. * Fixed a bug introduced in 2.7.5 that prevented a ConnectionError from being raised when the Redis server is LOADING data. * Added a BusyLoadingError exception that's raised when the Redis server is starting up and not accepting commands yet. BusyLoadingError subclasses ConnectionError, which this state previously returned. Thanks Yossi Gottlieb. * 2.7.5 * DEL, HDEL and ZREM commands now return the numbers of keys deleted instead of just True/False. * from_url now supports URIs with a port number. Thanks Aaron Westendorf.
Notes
Notes: svn path=/head/; revision=321029
Diffstat (limited to 'databases/py-redis')
-rw-r--r--databases/py-redis/Makefile4
-rw-r--r--databases/py-redis/distinfo4
-rw-r--r--databases/py-redis/files/patch-setup.py22
3 files changed, 9 insertions, 21 deletions
diff --git a/databases/py-redis/Makefile b/databases/py-redis/Makefile
index a2c58d764ff8..2ceb8a8fe1fe 100644
--- a/databases/py-redis/Makefile
+++ b/databases/py-redis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-PORTVERSION= 2.7.4
+PORTVERSION= 2.7.6
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,7 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= andymccurdy
GH_PROJECT= ${PORTNAME}-py
-GH_COMMIT= b5ccc73
+GH_COMMIT= a6302d9
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
diff --git a/databases/py-redis/distinfo b/databases/py-redis/distinfo
index bd176af35f33..71bf2b313803 100644
--- a/databases/py-redis/distinfo
+++ b/databases/py-redis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.7.4.tar.gz) = 054cd8c792d6bf6de90982e22d863b238e6febb37368f7086515ca73f2ab6e01
-SIZE (redis-2.7.4.tar.gz) = 54820
+SHA256 (redis-2.7.6.tar.gz) = 4fc95e2d38b54c0796b4f4229e51577f682558ff80416529258f5c0daec52331
+SIZE (redis-2.7.6.tar.gz) = 53524
diff --git a/databases/py-redis/files/patch-setup.py b/databases/py-redis/files/patch-setup.py
index 9d21f02976dc..4cb0b62ae6df 100644
--- a/databases/py-redis/files/patch-setup.py
+++ b/databases/py-redis/files/patch-setup.py
@@ -1,22 +1,10 @@
---- ./setup.py.orig 2012-08-10 08:48:07.000000000 +1000
-+++ ./setup.py 2012-08-15 22:27:30.000000000 +1000
-@@ -3,10 +3,7 @@
-
- from redis import __version__
-
--try:
-- from setuptools import setup
--except ImportError:
-- from distutils.core import setup
-+from setuptools import setup
-
- f = open(os.path.join(os.path.dirname(__file__), 'README.md'))
- long_description = f.read()
-@@ -41,5 +38,6 @@
+--- ./setup.py.orig 2013-06-16 18:54:43.668848521 +1000
++++ ./setup.py 2013-06-16 18:54:57.779885292 +1000
+@@ -57,5 +57,6 @@
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
-- ]
-+ ],
+- ]
++ ],
+ zip_safe=False,
)