aboutsummaryrefslogtreecommitdiff
path: root/databases/py-swift
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
commit4376dbbb58dab5a7bf7a8240ca39b562de78343b (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /databases/py-swift
parent6cb7ca00bb0a9a3aa67008824300ee8d16203a1b (diff)
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=472884
Diffstat (limited to 'databases/py-swift')
-rw-r--r--databases/py-swift/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/databases/py-swift/Makefile b/databases/py-swift/Makefile
index 044ef37af155..5f32077d28e1 100644
--- a/databases/py-swift/Makefile
+++ b/databases/py-swift/Makefile
@@ -13,18 +13,18 @@ COMMENT= Highly available, distributed, eventually consistent object/blob store
LICENSE= APACHE20
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.21:devel/py-pbr@${FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.21:devel/py-pbr@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}PasteDeploy>0:www/py-pastedeploy@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dnspython>=1.10.0:dns/py-dnspython@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9.8:net/py-eventlet@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}netifaces>=0:net/py-netifaces@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}python-swiftclient>=0:databases/py-python-swiftclient@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=0:devel/py-simplejson@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}webob>=0.9.8:www/py-webob@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}xattr>=0:devel/py-xattr@${FLAVOR} \
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}PasteDeploy>0:www/py-pastedeploy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>=1.10.0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9.8:net/py-eventlet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netifaces>=0:net/py-netifaces@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-swiftclient>=0:databases/py-python-swiftclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=0:devel/py-simplejson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webob>=0.9.8:www/py-webob@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xattr>=0:devel/py-xattr@${PY_FLAVOR} \
memcached>=0:databases/memcached \
rsync>=3.0:net/rsync