aboutsummaryrefslogtreecommitdiff
path: root/databases/py-swiftclient/Makefile
diff options
context:
space:
mode:
authorMikolaj Golub <trociny@FreeBSD.org>2013-07-30 19:33:16 +0000
committerMikolaj Golub <trociny@FreeBSD.org>2013-07-30 19:33:16 +0000
commit45673e39177207cb7bd6dadca6a480698c125739 (patch)
tree112d63471869af4e0630b228f731b47f80757b8d /databases/py-swiftclient/Makefile
parent33179c4035525ed61df857d718b75427a812e82c (diff)
downloadports-45673e39177207cb7bd6dadca6a480698c125739.tar.gz
ports-45673e39177207cb7bd6dadca6a480698c125739.zip
Notes
Diffstat (limited to 'databases/py-swiftclient/Makefile')
-rw-r--r--databases/py-swiftclient/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/databases/py-swiftclient/Makefile b/databases/py-swiftclient/Makefile
index 778cc617f302..6798ac3a9229 100644
--- a/databases/py-swiftclient/Makefile
+++ b/databases/py-swiftclient/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= swiftclient
-PORTVERSION= 1.4.0
+PORTVERSION= 1.5.0
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,9 @@ COMMENT= Python client library for OpenStack Object Storage (Swift)
LICENSE= AL2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>0:${PORTSDIR}/devel/py-simplejson
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.19:${PORTSDIR}/devel/py-pbr
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.9:${PORTSDIR}/devel/py-simplejson
USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
@@ -24,6 +26,10 @@ PLIST_FILES= bin/swift \
MAN1= swift.1
+post-patch:
+ @${REINPLACE_CMD} -e "s/'d2to1', //; s/d2to1=True/pbr=True/" \
+ ${WRKSRC}/setup.py
+
post-install:
.for i in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/doc/manpages/${i} ${MANPREFIX}/man/man1/${i}