aboutsummaryrefslogtreecommitdiff
path: root/databases/py-tiledb
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 03:57:08 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:17 +0000
commit4eceac7a00bc1a6bca9ee85eb3d4926eb32fb57e (patch)
treec34d043231da06c23e51db53319bfc8de3b9d63b /databases/py-tiledb
parent277d92981f99d19f9a383b7b797e732d517d971d (diff)
downloadports-4eceac7a00bc1a6bca9ee85eb3d4926eb32fb57e.tar.gz
ports-4eceac7a00bc1a6bca9ee85eb3d4926eb32fb57e.zip
Diffstat (limited to 'databases/py-tiledb')
-rw-r--r--databases/py-tiledb/Makefile4
-rw-r--r--databases/py-tiledb/distinfo6
-rw-r--r--databases/py-tiledb/files/patch-requirements_dev.txt5
-rw-r--r--databases/py-tiledb/files/patch-setup.py4
4 files changed, 10 insertions, 9 deletions
diff --git a/databases/py-tiledb/Makefile b/databases/py-tiledb/Makefile
index 149cada6e1fd..1b563b02ac4c 100644
--- a/databases/py-tiledb/Makefile
+++ b/databases/py-tiledb/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= tiledb
-PORTVERSION= 0.13.1
+PORTVERSION= 0.13.2
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.27:lang/cython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.19.2,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pybind11>=2.6.2:devel/py-pybind11@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.5.4:devel/py-setuptools_scm@${PY_FLAVOR} \
- tiledb>=2.7.1:databases/tiledb
+ tiledb>=2.7.2:databases/tiledb
LIB_DEPENDS= libtiledb.so:databases/tiledb
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.19.2,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
diff --git a/databases/py-tiledb/distinfo b/databases/py-tiledb/distinfo
index 17040ba75b72..591085f7bd59 100644
--- a/databases/py-tiledb/distinfo
+++ b/databases/py-tiledb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1648248888
-SHA256 (tiledb-0.13.1.tar.gz) = 4edfde468f948bdb7d4a0ada5bc1764b51110320c2badb951df09b18b2f8080f
-SIZE (tiledb-0.13.1.tar.gz) = 249560
+TIMESTAMP = 1649423752
+SHA256 (tiledb-0.13.2.tar.gz) = 140e7ffe0b78f4ccc128c755134073b9565397d6e7b3e85f1bda4e9f0641bd97
+SIZE (tiledb-0.13.2.tar.gz) = 263271
diff --git a/databases/py-tiledb/files/patch-requirements_dev.txt b/databases/py-tiledb/files/patch-requirements_dev.txt
index 15e9adcaeb45..a2cb99746e97 100644
--- a/databases/py-tiledb/files/patch-requirements_dev.txt
+++ b/databases/py-tiledb/files/patch-requirements_dev.txt
@@ -1,4 +1,4 @@
---- requirements_dev.txt.orig 2022-01-25 22:10:16 UTC
+--- requirements_dev.txt.orig 2022-03-31 21:51:37 UTC
+++ requirements_dev.txt
@@ -1,14 +1,8 @@
numpy >= 1.16.5
@@ -10,7 +10,8 @@
-cmake >= 3.21, < 3.22
cython >= 0.27
pybind11 >= 2.6.2
- setuptools >= 18.0
+-setuptools >= 18.0, < 61.0
++setuptools >= 18.0
setuptools_scm >= 1.5.4
-wheel >= 0.30
contextvars ;python_version<"3.7"
diff --git a/databases/py-tiledb/files/patch-setup.py b/databases/py-tiledb/files/patch-setup.py
index ed37abc0eacd..432744168cd3 100644
--- a/databases/py-tiledb/files/patch-setup.py
+++ b/databases/py-tiledb/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2022-01-25 22:10:16 UTC
+--- setup.py.orig 2022-03-31 21:51:37 UTC
+++ setup.py
-@@ -503,12 +503,6 @@ def setup_requires():
+@@ -518,12 +518,6 @@ def setup_requires():
req = parse_requirements("requirements_dev.txt")
req = list(filter(lambda r: not r.startswith("-r"), req))