aboutsummaryrefslogtreecommitdiff
path: root/databases/py-whisper
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2016-01-29 21:13:47 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2016-01-29 21:13:47 +0000
commit2810fa130401d1b6cc5e8987bd613c0226220e18 (patch)
tree12cdebae1aff0ca642a8f9173f612e5bb6ffdf8b /databases/py-whisper
parent08689737c048750f58dda6d30595805fdba101c1 (diff)
downloadports-2810fa130401d1b6cc5e8987bd613c0226220e18.tar.gz
ports-2810fa130401d1b6cc5e8987bd613c0226220e18.zip
Update to 0.9.15
PR: 206531 Submitted by: Michael Zhilin <mizhka@gmail.com>
Notes
Notes: svn path=/head/; revision=407496
Diffstat (limited to 'databases/py-whisper')
-rw-r--r--databases/py-whisper/Makefile2
-rw-r--r--databases/py-whisper/distinfo4
-rw-r--r--databases/py-whisper/files/patch-whisper.py13
-rw-r--r--databases/py-whisper/pkg-plist2
4 files changed, 18 insertions, 3 deletions
diff --git a/databases/py-whisper/Makefile b/databases/py-whisper/Makefile
index de278bbbb627..28b8413b1e73 100644
--- a/databases/py-whisper/Makefile
+++ b/databases/py-whisper/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= whisper
-PORTVERSION= 0.9.12
+PORTVERSION= 0.9.15
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/py-whisper/distinfo b/databases/py-whisper/distinfo
index c3c8342ffe9e..0cccd0bee95b 100644
--- a/databases/py-whisper/distinfo
+++ b/databases/py-whisper/distinfo
@@ -1,2 +1,2 @@
-SHA256 (graphite-project-whisper-0.9.12_GH0.tar.gz) = 5012e595a980658885ceb010d9dcd0e4ac664c24de6206a6b2430d1d8f60a679
-SIZE (graphite-project-whisper-0.9.12_GH0.tar.gz) = 16655
+SHA256 (graphite-project-whisper-0.9.15_GH0.tar.gz) = 737706917215d63c311639cc87a0106c660b543faf620c418f52dd66dde20e07
+SIZE (graphite-project-whisper-0.9.15_GH0.tar.gz) = 21083
diff --git a/databases/py-whisper/files/patch-whisper.py b/databases/py-whisper/files/patch-whisper.py
new file mode 100644
index 000000000000..27b2dc3a74d3
--- /dev/null
+++ b/databases/py-whisper/files/patch-whisper.py
@@ -0,0 +1,13 @@
+--- whisper.py.orig 2016-01-18 10:45:34 UTC
++++ whisper.py
+@@ -48,6 +48,10 @@ if CAN_FALLOCATE:
+ c_off64_t = ctypes.c_int64
+ c_off_t = ctypes.c_int
+
++ if os.uname()[0] == 'FreeBSD':
++ # offset type is 64-bit on FreeBSD 32-bit & 64-bit platforms to address files more than 2GB
++ c_off_t = ctypes.c_int64
++
+ try:
+ _fallocate = libc.posix_fallocate64
+ _fallocate.restype = ctypes.c_int
diff --git a/databases/py-whisper/pkg-plist b/databases/py-whisper/pkg-plist
index 7549568a8932..ab63cbba5283 100644
--- a/databases/py-whisper/pkg-plist
+++ b/databases/py-whisper/pkg-plist
@@ -1,7 +1,9 @@
bin/rrd2whisper.py
bin/whisper-create.py
+bin/whisper-diff.py
bin/whisper-dump.py
bin/whisper-fetch.py
+bin/whisper-fill.py
bin/whisper-info.py
bin/whisper-merge.py
bin/whisper-resize.py